summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-21 12:53:21 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-21 14:24:47 +0100
commit68fbd29cce7a8677487a0430fdca252e07ddd420 (patch)
treee0247166694cf7c1f9e1f73883869e34675a176e /dev-python/python-cstruct
parentdev-python/pip-run: Bump to 8.8.2 (diff)
downloadgentoo-68fbd29cce7a8677487a0430fdca252e07ddd420.tar.gz
gentoo-68fbd29cce7a8677487a0430fdca252e07ddd420.tar.bz2
gentoo-68fbd29cce7a8677487a0430fdca252e07ddd420.zip
dev-python/python-cstruct: Bump to 5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-cstruct')
-rw-r--r--dev-python/python-cstruct/Manifest1
-rw-r--r--dev-python/python-cstruct/python-cstruct-5.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 0e0100bcfb1b..62acfc7168d3 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -1 +1,2 @@
DIST python-cstruct-5.0.gh.tar.gz 36194 BLAKE2B 436998e52f2cfa714eb49c606a76b2ae72af959c58addbd2cff036a3ecd6bfea22e43da2c6c17a2d4c1328578385ecd8605afbc3dcdcb4e083125588a6020751 SHA512 f28977ae0b4db9bed0b5757f257b772089dd37844cb47455be3c406f5e5245194f98eae98520ad9888306e31a581617229b8634d0e5881c38c0e8deb84bc5ef8
+DIST python-cstruct-5.1.gh.tar.gz 37905 BLAKE2B 0559e09ed16cb171e6fa5ab6e92150c986579b25b19cce4b3e0e23e0969bb02a5598a25b8f3b412aae04c4522dc25b66a9d9d310a661ca4657896d9e16811c81 SHA512 28a0221b63074a83704c0bade58b7a0d195ec56057bdee9b6e4c15c76619ee20854155ff7a4910909c0e82ad81c92c01c67ffc6e1eb2b8d702911ad8a1392dd0
diff --git a/dev-python/python-cstruct/python-cstruct-5.1.ebuild b/dev-python/python-cstruct/python-cstruct-5.1.ebuild
new file mode 100644
index 000000000000..e1a88b9460d4
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="
+ https://github.com/andreax79/python-cstruct/
+ https://pypi.org/project/cstruct/
+"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest