summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-cdb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-cdb')
-rw-r--r--dev-python/python-cdb/Manifest1
-rw-r--r--dev-python/python-cdb/metadata.xml5
-rw-r--r--dev-python/python-cdb/python-cdb-0.34-r1.ebuild26
-rw-r--r--dev-python/python-cdb/python-cdb-0.34.ebuild33
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/python-cdb/Manifest b/dev-python/python-cdb/Manifest
new file mode 100644
index 000000000000..140fe6d52d38
--- /dev/null
+++ b/dev-python/python-cdb/Manifest
@@ -0,0 +1 @@
+DIST python-cdb-0.34.tar.gz 18865 SHA256 31c4c272d02c8f9ca66394c36be677fd9ea1813782cac73efacc5add2cbd677c SHA512 712e4c91d6285b8ce3436fb4c18f8cd0db76aad12eda96e860a1f0b72ecd480181e33315595dab4a2242149372166b0ca8a6c367ea808e394af4bd9f15d6733a WHIRLPOOL b4ee8802fb14abb27d78bbab0f28791c1960b65456c1d6ce317976ec322daab4ee85c09b3a50247ae2c9b9d413cf937f533d13a0542797c5eb05bbeee2dd7002
diff --git a/dev-python/python-cdb/metadata.xml b/dev-python/python-cdb/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/python-cdb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/python-cdb/python-cdb-0.34-r1.ebuild b/dev-python/python-cdb/python-cdb-0.34-r1.ebuild
new file mode 100644
index 000000000000..d823701a2f4c
--- /dev/null
+++ b/dev-python/python-cdb/python-cdb-0.34-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python extension module for cdb"
+SRC_URI="http://pilcrow.madison.wi.us/python-cdb/${P}.tar.gz"
+HOMEPAGE="http://pilcrow.madison.wi.us/#pycdb"
+
+SLOT="0"
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="|| ( dev-db/cdb dev-db/tinycdb )"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${PYTHON}" setup.py build -b "build-${PYTHON_ABI}" install --home "${T}/test-${PYTHON_ABI}" || return 1
+ # This is not really intended as test but it is better than nothing.
+ "${PYTHON}" < Example
+}
diff --git a/dev-python/python-cdb/python-cdb-0.34.ebuild b/dev-python/python-cdb/python-cdb-0.34.ebuild
new file mode 100644
index 000000000000..72a65d4d1d4e
--- /dev/null
+++ b/dev-python/python-cdb/python-cdb-0.34.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="A Python extension module for cdb"
+SRC_URI="http://pilcrow.madison.wi.us/python-cdb/${P}.tar.gz"
+HOMEPAGE="http://pilcrow.madison.wi.us/#pycdb"
+
+SLOT="0"
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="amd64 arm ia64 ppc sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="|| ( dev-db/cdb dev-db/tinycdb )"
+RDEPEND="${DEPEND}"
+
+DOCS="Example"
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home "${T}/test-${PYTHON_ABI}" || return 1
+ # This is not really intended as test but it is better than nothing.
+ PYTHONPATH="${T}/test-${PYTHON_ABI}/lib/python" "$(PYTHON)" < Example
+ }
+ python_execute_function testing
+}