summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-28 07:06:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-28 07:31:51 +0200
commit48fe974e94acda51f111a302f04d6a75dd0efc8e (patch)
treec1e47db6467837d6e7926d12f62c889103ed0ac7 /dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild
parentdev-python/google-auth: Bump to 1.34.0 (diff)
downloadgentoo-48fe974e94acda51f111a302f04d6a75dd0efc8e.tar.gz
gentoo-48fe974e94acda51f111a302f04d6a75dd0efc8e.tar.bz2
gentoo-48fe974e94acda51f111a302f04d6a75dd0efc8e.zip
dev-python/python-bugzilla: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild')
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild
new file mode 100644
index 000000000000..137bbf61ee25
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest