summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 17:08:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 17:37:31 +0200
commit8a98ce70a92b25008facabfb3d9e3a41ec3479f3 (patch)
tree5d70cce4480b8ecc24dc013ae3ea94d5f931e7fb /dev-python/pytest
parentdev-python/wcwidth: Remove python2 (diff)
downloadgentoo-8a98ce70a92b25008facabfb3d9e3a41ec3479f3.tar.gz
gentoo-8a98ce70a92b25008facabfb3d9e3a41ec3479f3.tar.bz2
gentoo-8a98ce70a92b25008facabfb3d9e3a41ec3479f3.zip
dev-python/pytest: Revert "Remove tests in <5 to unblock deps"
Now that pytest no longer supports Python 2, we can trivially restore tests. Reverts: fa31124dffc6a0de0cb8aa9bfc3371e5a6443898 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-4.6.11-r1.ebuild34
1 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/pytest/pytest-4.6.11-r1.ebuild b/dev-python/pytest/pytest-4.6.11-r1.ebuild
index d554a922429e..4eaec4d546f8 100644
--- a/dev-python/pytest/pytest-4.6.11-r1.ebuild
+++ b/dev-python/pytest/pytest-4.6.11-r1.ebuild
@@ -15,7 +15,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-RESTRICT="test"
+IUSE="test"
+RESTRICT="!test? ( test )"
# When bumping, please check setup.py for the proper py version
PY_VER="1.5.0"
@@ -40,6 +41,23 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/wcwidth[${PYTHON_USEDEP}]"
+# flake cause a number of tests to fail
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ !!dev-python/pytest-aiohttp
+ !!dev-python/pytest-asyncio
+ !!dev-python/pytest-django
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )"
+
PATCHES=(
"${FILESDIR}/pytest-4.5.0-strip-setuptools_scm.patch"
"${FILESDIR}/pytest-4.6.10-timeout.patch"
@@ -48,5 +66,19 @@ PATCHES=(
python_prepare_all() {
grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
distutils-r1_python_prepare_all
}
+
+python_test() {
+ distutils_install_for_testing
+
+ # In v4.1.1, pytest started being picky about its own verbosity options.
+ # running pytest on itself with -vv made 3 tests fail. This is why we don't
+ # have it below.
+ "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
+}