summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:02:01 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:06:51 +0300
commit72bb2f3fe55b732b46cbecd7162995306f3cc318 (patch)
tree5e674245b790744148f6b46d6efcb493a6851910 /dev-python/pytest-shell-utilities
parentdev-python/bibtexparser: drop 1.2.0-r2 (diff)
downloadgentoo-72bb2f3fe55b732b46cbecd7162995306f3cc318.tar.gz
gentoo-72bb2f3fe55b732b46cbecd7162995306f3cc318.tar.bz2
gentoo-72bb2f3fe55b732b46cbecd7162995306f3cc318.zip
dev-python/pytest-shell-utilities: add 1.7.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest1
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.7.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
index a1defee2bdbc..2615c2546e30 100644
--- a/dev-python/pytest-shell-utilities/Manifest
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -1 +1,2 @@
DIST pytest-shell-utilities-1.6.0.gh.tar.gz 92343 BLAKE2B 39239aff1d7d4970a706926ea9f4c7808f8c12760d8f1ccaff760d8320024bba7373a25bb2ad8db2e0a6fee1f8ef4dd5b85b4e7eb1fb6e2aab64711686acf25e SHA512 e979f5bbf34de99c1dac33b4cb27265a210852d39792cd7660b717e43de0baaf47785d57ade226f08de43ef9d83600b4e46f70ceed341c7fccde554f7a838b8e
+DIST pytest-shell-utilities-1.7.0.gh.tar.gz 93366 BLAKE2B 95a04ec484c43f48d7d3e120e8bfef0ce9d31b6d119cbb1f3cde0a7db540e6fd98da88a32af921e5748577a46a28c43f7c83c9d3a3d1a33b7277e3ac5cf0dc56 SHA512 d59c1f04106eb2de6cf9f7ffe873344cf69691bd336c1dee6b328c083090f52479bbe4990c36e024b9f2a9c0817ba711343477574ae3ee5620643d5de8c57cc6
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.7.0.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.7.0.ebuild
new file mode 100644
index 000000000000..84d66d2dc910
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}