summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-20 17:23:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-20 17:33:01 +0100
commit4784217153586cdfd84cf2dd5c1bfa02d625403f (patch)
tree54963090da17c9e29659b68ea24f9865f0ff4a93 /dev-python/pytest-qt
parentdev-python/pytest-qt: Fix calling the test phase (diff)
downloadgentoo-4784217153586cdfd84cf2dd5c1bfa02d625403f.tar.gz
gentoo-4784217153586cdfd84cf2dd5c1bfa02d625403f.tar.bz2
gentoo-4784217153586cdfd84cf2dd5c1bfa02d625403f.zip
dev-python/pytest-qt: Disable plugin autoloading to fix tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.0.2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-4.0.2.ebuild b/dev-python/pytest-qt/pytest-qt-4.0.2.ebuild
index c11cb485179f..42c994fad350 100644
--- a/dev-python/pytest-qt/pytest-qt-4.0.2.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-4.0.2.ebuild
@@ -49,6 +49,10 @@ src_test() {
}
python_test() {
+ # warnings from other plugins cause the test output matchers to fail
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytestqt.plugin
+
distutils_install_for_testing
PYTEST_QT_API="pyqt5" epytest || die
if [[ "${EPYTHON}" == "python3.10" ]]; then