summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-09 06:23:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-09 07:26:44 +0200
commite7eec3f32427a73e132f24cf9470cd85d28226dd (patch)
treea3c5087c33e39577ad2ac3b9efa8a3b6ccbc04c2 /dev-python/pytest-httpbin
parentdev-python/flask-babel: Remove old (diff)
downloadgentoo-e7eec3f32427a73e132f24cf9470cd85d28226dd.tar.gz
gentoo-e7eec3f32427a73e132f24cf9470cd85d28226dd.tar.bz2
gentoo-e7eec3f32427a73e132f24cf9470cd85d28226dd.zip
dev-python/pytest-httpbin: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest1
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
index e3ee1b204a3e..bf5af2cacf98 100644
--- a/dev-python/pytest-httpbin/Manifest
+++ b/dev-python/pytest-httpbin/Manifest
@@ -1 +1,2 @@
DIST pytest-httpbin-1.0.2.gh.tar.gz 18727 BLAKE2B 56a7fa1c1694cad98815fc6c6f676b509942fa1fca192ecb4cb5a0d9f325d7df6ddb3a3ac67d884c8f8caba807677351c42c28a3bcba80b9196e74d666951cc2 SHA512 b4adac1c37506391d83f7772814b4a9ce5134cc6834d8758e71d39610f8b29e57e72b11b2233be51e41b2c36bc305d40fc4b260a7f83d10390f4e940df8aa366
+DIST pytest-httpbin-2.0.0.gh.tar.gz 19799 BLAKE2B 7725bc958417c076ee920abce83bdad8295bc4c9551500040867650d54c306e79a1ea92b013124b793058103fc9685dbb2202be5f1b2da935509f68457d63d68 SHA512 62876590bacae6601739f5cc2eccb087024e16731afc9613b5e6928c2a2f64b73418ddcb3c4f13a4bfe1f074510f922d85411d05ebf66f123a4a09d535771b64
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild
new file mode 100644
index 000000000000..cb8d6dcf63a2
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="
+ https://github.com/kevin1024/pytest-httpbin/
+ https://pypi.org/project/pytest-httpbin/
+"
+SRC_URI="
+ https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/httpbin[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ tests/test_server.py::test_redirect_location_is_https_for_secure_server
+ # minor exception message mismatch on pypy3
+ # https://github.com/kevin1024/pytest-httpbin/issues/77
+ tests/test_server.py::test_dont_crash_on_handshake_timeout
+)
+
+distutils_enable_tests pytest