summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-19 09:20:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-19 10:36:01 +0100
commitaa7d4021e58a4c2814b6b4c87ec8f1c3f76c0b76 (patch)
treeed45b7b782947952a3a4967e3089f547d402948f /dev-python/pytest-flake8
parentsci-libs/libigl: add 2.4.0 (diff)
downloadgentoo-aa7d4021e58a4c2814b6b4c87ec8f1c3f76c0b76.tar.gz
gentoo-aa7d4021e58a4c2814b6b4c87ec8f1c3f76c0b76.tar.bz2
gentoo-aa7d4021e58a4c2814b6b4c87ec8f1c3f76c0b76.zip
dev-python/pytest-flake8: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-flake8')
-rw-r--r--dev-python/pytest-flake8/Manifest1
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/Manifest b/dev-python/pytest-flake8/Manifest
index 42eabff6661b..bc3a748b9462 100644
--- a/dev-python/pytest-flake8/Manifest
+++ b/dev-python/pytest-flake8/Manifest
@@ -1,2 +1,3 @@
DIST pytest-flake8-1.0.7.tar.gz 9560 BLAKE2B 056066a6693fa6988448662e52856eeed49688e834b344e5f60f31f1c3b3ef89043dba06bddbf958b042ab9e702fec056784b252e96c8b4b46fe350a801535cf SHA512 16e7b437ff9fc9afd3520f6b81d9eafeda840c7cd7925f5287ce0e0d5b20a0fa758183cea7ade369e3fec8606eee976e84c5b3142923e4586f559232012bf3a3
DIST pytest-flake8-1.1.0.tar.gz 9070 BLAKE2B fbf4e0d6480b26729aa43d6d7f05d19950c60b0ad047d5c0a788bccde0bf82805122480575022bb46919599208225f0bcbaf2c4e68d2a875814c1f6540fc35b2 SHA512 3dd060e711d2540e65583b299809c82d70969d3a13e17cb3cc2f7d92e6cfa841ceefb046d4c1a57e9b198b64711114936983d18b9f89ebefa3d5798f5d158215
+DIST pytest-flake8-1.1.1.tar.gz 9144 BLAKE2B 4f9984181cbadf1d14f2bfaa39a801eb40506457d5178e04a80d49afbd2e54ef10feef0c6cf99ac888442ee75df15663b4f7fa86ff392f34ee4615cbf12f7d13 SHA512 c6fed2228520501bc0c007c90b189d43953391c10fe93fdd7c4c68203ddfc64937b9919730f25ebcba0c1003ed266fbcb35d3ab12ed49fb63503bf27615286c0
diff --git a/dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild b/dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild
new file mode 100644
index 000000000000..80ff41385fa4
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for flake8"
+HOMEPAGE="
+ https://github.com/tholo/pytest-flake8/
+ https://pypi.org/project/pytest-flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/flake8-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p flake8
+}