summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-23 12:24:17 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-23 12:24:17 +0100
commit1a74ce55ece3d1f11238daed9644ec2397d6b2f5 (patch)
treeb343afa519ae0d21a71a23e81bf714c89d5fa2a3 /dev-python/pytest-env
parentnet-libs/paho-mqtt-c: add REQUIRED_USE="examples? ( ssl )" (diff)
downloadgentoo-1a74ce55ece3d1f11238daed9644ec2397d6b2f5.tar.gz
gentoo-1a74ce55ece3d1f11238daed9644ec2397d6b2f5.tar.bz2
gentoo-1a74ce55ece3d1f11238daed9644ec2397d6b2f5.zip
dev-python/pytest-env: add 1.0.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/Manifest1
-rw-r--r--dev-python/pytest-env/pytest-env-1.0.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
index a4ed164ee9f3..2edb2ba86520 100644
--- a/dev-python/pytest-env/Manifest
+++ b/dev-python/pytest-env/Manifest
@@ -1 +1,2 @@
DIST pytest_env-0.8.2.tar.gz 7419 BLAKE2B c07140de76392bcf316935efaa52aea344c7167a95fe497c3702dd2aabc3150641f0903f2de6ee1794453dc2e5b1630d746b2fcb3dbcea8edb9ba066cde0a0b4 SHA512 6fbbb6b1db21ebeb47c472e10adb9bacedcdbbabceeaf93b01146ec7e175005aeef46616a4343bf02b23561c0ff5815506fe356f337371dfc057ee29521f68af
+DIST pytest_env-1.0.0.tar.gz 7456 BLAKE2B 9eaf71aa05a9a4b8783184dce1f1779b5ee54da54839f1113c9276df7cb4c4ef6055aadad7d20063d4c5c24654f2d100970bdae540eac49b89f049b78be49e93 SHA512 9d25c704e253c11e77933911817ba2b42127c13c38615e1cbf11575cfced81c69a46603bef680ee371512788acb6359a76841019837d55151490fd1f093bb83b
diff --git a/dev-python/pytest-env/pytest-env-1.0.0.ebuild b/dev-python/pytest-env/pytest-env-1.0.0.ebuild
new file mode 100644
index 000000000000..db479a2c1572
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-1.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="py.test plugin that allows you to add environment variables"
+HOMEPAGE="https://github.com/pytest-dev/pytest-env"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND=">=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest