summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-02 23:38:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-03 00:13:01 +0100
commitb7be9fb5d393da00c5515e78c28e8c8390b66745 (patch)
treec287c19713eb82648ff0502702d2480423be8bf6 /dev-python/pytest-django
parentdev-python/hypothesis: Bump to 6.29.3 (diff)
downloadgentoo-b7be9fb5d393da00c5515e78c28e8c8390b66745.tar.gz
gentoo-b7be9fb5d393da00c5515e78c28e8c8390b66745.tar.bz2
gentoo-b7be9fb5d393da00c5515e78c28e8c8390b66745.zip
dev-python/pytest-django: Bump to 4.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-4.5.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 0e1b28eeecf6..50325da8149f 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,2 +1,3 @@
DIST pytest-django-4.4.0.gh.tar.gz 72905 BLAKE2B 4532bef9afdc7f11fdf9a16f019810d10e4e580b517958722184d361a69a195f6c66f7f3bc18be6cb7f63fe4576963c59a00d72bd8a42f104d26e5ad091c6d54 SHA512 47e4a84606aeb6bb99ed74603faf988298d52f81f74ec8e4608cb670f0f331ad0c6555f3e4a516fc7834aea4e634f849dc0ff6d446a86e924a116fbe90bd79e0
DIST pytest-django-4.5.0.gh.tar.gz 75264 BLAKE2B 7743e21cd397cb5620a9a4ba73edf049c9540a64ba675baabd768c6060872eb2911384346f21c598469db604b78084f27e7e6da7423fc26cb7c550934cf4ed49 SHA512 9d86a35a05521e1cc3582f17fd6d78367d0d8383ee06e5a2f97ea5da658be4008471094d6c0b4c1d43da3091cf7e936e40ec984d232f9e3cc8cf69cd88adb9b9
+DIST pytest-django-4.5.1.gh.tar.gz 75348 BLAKE2B 36bac4524ee4dab37ee661780fd4033f16a29677fa00a35ad345f092c46454eb67fcbb111e2422221ebf335a1046e353ed53f2b029b493c82eac7f435d1a275c SHA512 cddc87b989933b2537caaf3d369ec101331ce544a8e66298d170b985810f21425059eb9a516fe37d97cbb5a38a430410cfff4da086d82d62689b65215b59cc66
diff --git a/dev-python/pytest-django/pytest-django-4.5.1.ebuild b/dev-python/pytest-django/pytest-django-4.5.1.ebuild
new file mode 100644
index 000000000000..1e62d7f0b421
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-configurations[${PYTHON_USEDEP}]
+ )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # something else may be loading it
+ tests/test_django_settings_module.py::test_django_not_loaded_without_settings
+ )
+
+ distutils_install_for_testing
+ cp -r pytest_django_test "${TEST_DIR}"/lib || die
+
+ local -x DJANGO_SETTINGS_MODULE
+ for DJANGO_SETTINGS_MODULE in pytest_django_test.settings_sqlite{,_file}; do
+ einfo "Testing ${DJANGO_SETTINGS_MODULE}"
+ epytest tests
+ done
+}