summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-27 19:46:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-27 19:46:10 +0100
commit6cd3714880e4cd6d40b108703b86021daacea5fd (patch)
treebf528563e94a44a738efc4f554ffc038498c21fd /dev-python/pytest-cov
parentdev-python/pyphen: Remove old (diff)
downloadgentoo-6cd3714880e4cd6d40b108703b86021daacea5fd.tar.gz
gentoo-6cd3714880e4cd6d40b108703b86021daacea5fd.tar.bz2
gentoo-6cd3714880e4cd6d40b108703b86021daacea5fd.zip
dev-python/pytest-cov: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/pytest-cov-3.0.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild b/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
deleted file mode 100644
index 9c14153ab26d..000000000000
--- a/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-# TODO: figure out how to make tests work without pytest-cov installed
-# first
-BDEPEND="
- test? (
- ~dev-python/pytest-cov-${PV}[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-py3doc-enhanced-theme
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/pytest-dev/pytest-cov/pull/518
- "${FILESDIR}"/${P}-coverage-6.2.patch
-)
-
-python_test() {
- # NB: disabling all plugins speeds tests up a lot
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_cov.plugin,xdist.plugin,xdist.looponfail
-
- local EPYTEST_DESELECT=(
- # attempts to install packages via pip (network)
- tests/test_pytest_cov.py::test_dist_missing_data
- )
-
- epytest
-}