summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-11 08:13:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-11 08:34:51 +0200
commit1458d4e1f8f0256a6389a753000298e2d9de7dbf (patch)
tree059c9c276b1b75740644672a802c42ba483eb00e /dev-python/pytest-aiohttp
parentdev-python/aioresponses: Add pypi HOMEPAGE (diff)
downloadgentoo-1458d4e1f8f0256a6389a753000298e2d9de7dbf.tar.gz
gentoo-1458d4e1f8f0256a6389a753000298e2d9de7dbf.tar.bz2
gentoo-1458d4e1f8f0256a6389a753000298e2d9de7dbf.zip
dev-python/pytest-aiohttp: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
index 1ad54bae78d3..d009d00e3de7 100644
--- a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
@@ -4,12 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="pytest plugin for aiohttp support"
-HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+HOMEPAGE="
+ https://github.com/aio-libs/pytest-aiohttp/
+ https://pypi.org/project/pytest-aiohttp/
+"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
@@ -26,3 +29,9 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning doesn't seem to be emitted for some reason
+ # doesn't look very important
+ tests/test_obsolete_fixtures.py::test_loop_fixture
+)