summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-26 00:50:42 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-26 01:23:32 +0200
commitb73debca0270dbf3e8c831f1907d8bf84c5fc8b4 (patch)
tree6e51c2b1d76346b7956909eb1ee6ceea9d8110b4 /dev-python/pysrt
parentdev-python/python-ctags: fix bugs-to URL in metadata.xml (diff)
downloadgentoo-b73debca0270dbf3e8c831f1907d8bf84c5fc8b4.tar.gz
gentoo-b73debca0270dbf3e8c831f1907d8bf84c5fc8b4.tar.bz2
gentoo-b73debca0270dbf3e8c831f1907d8bf84c5fc8b4.zip
dev-python/pysrt: add Python 3.7, PyPy{,3}, don't run coverage tests
Also use a proper PyPI URL since those work again, make tests verbose and update license to GPl-3 or later. Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/pysrt-1.1.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pysrt/pysrt-1.1.1-r1.ebuild b/dev-python/pysrt/pysrt-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..5ceb7f709502
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests failed under ${EPYTHON}"
+}