summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-11-18 16:14:27 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-11-18 16:23:01 -0600
commitf155efca3b34d69ca0fccfcee198055d3caca26d (patch)
tree5c8d1413fd136783578b963e0be4239083571084 /dev-python/pysaml2
parentsys-apps/haveged: fix Manifest, bug #637982 (diff)
downloadgentoo-f155efca3b34d69ca0fccfcee198055d3caca26d.tar.gz
gentoo-f155efca3b34d69ca0fccfcee198055d3caca26d.tar.bz2
gentoo-f155efca3b34d69ca0fccfcee198055d3caca26d.zip
dev-python/pysaml2: bup to 4.5.0
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/pysaml2')
-rw-r--r--dev-python/pysaml2/Manifest1
-rw-r--r--dev-python/pysaml2/pysaml2-4.5.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pysaml2/Manifest b/dev-python/pysaml2/Manifest
index 9d9179a7a771..f448a757b75a 100644
--- a/dev-python/pysaml2/Manifest
+++ b/dev-python/pysaml2/Manifest
@@ -1 +1,2 @@
DIST pysaml2-4.0.2.tar.gz 13657558 SHA256 24cec8dbc20a7772854563ffc9a19297afcc38c4c7558c063b4c8c302f8a958b SHA512 debe23c2b193ca9f937bdb4fc9e8f308fa012c18e50e40183f7e531434af52b6e4d36608be3e9b0321190930cdfd9eb24555ed1805083e32db8de0f57e5afb14 WHIRLPOOL 303217ea7408986435a31ac97deae3d2b14393674d360d30cbdacf1c673d265b21505af1dea8c536c4698dc6861058f6e57421aaa5bb411daa68d5d02c1ba2c2
+DIST pysaml2-4.5.0.tar.gz 20030696 SHA256 59f82ee82390482640b298045a792455dae6cae580d8c0a3c935f0038f878133 SHA512 163dfc2acfa0f242bc97d3ec334aec98e993ef9265b2240223205e496f86df5518ca613620b371eabcca0c4070a0bf7bb72a2216f517e19e3b2ff0f20e30a0c7 WHIRLPOOL f01b77c2867023847f4276f9fc7f065d84796ed39ac7bbcba5ce9d6a9d9641486da90bcd11eb284fa679c8e699c8fabbfd5f52a0b9b7a7c29f446193d4142746
diff --git a/dev-python/pysaml2/pysaml2-4.5.0.ebuild b/dev-python/pysaml2/pysaml2-4.5.0.ebuild
new file mode 100644
index 000000000000..651a17f3dedb
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-4.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
+HOMEPAGE="https://github.com/rohe/pysaml2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+PATCHES=(
+
+)
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"