summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-25 17:58:49 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-25 23:49:19 +0200
commit7523d3ebbbdec0ea5bccedce6185a5454e01a39e (patch)
treef75c212d1f03d5087dc1e1b2d2b9192ac3af3a4c /dev-python/pypy3
parentdev-python/pypy3: Remove CPython patchset in 9999 (diff)
downloadgentoo-7523d3ebbbdec0ea5bccedce6185a5454e01a39e.tar.gz
gentoo-7523d3ebbbdec0ea5bccedce6185a5454e01a39e.tar.bz2
gentoo-7523d3ebbbdec0ea5bccedce6185a5454e01a39e.zip
dev-python/pypy3: Bump 9999 to EAPI 6
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/files/2.5.0-shared-lib.patch4
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild14
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/pypy3/files/2.5.0-shared-lib.patch b/dev-python/pypy3/files/2.5.0-shared-lib.patch
index ddd74730f3dd..b5c877bd58b2 100644
--- a/dev-python/pypy3/files/2.5.0-shared-lib.patch
+++ b/dev-python/pypy3/files/2.5.0-shared-lib.patch
@@ -1,6 +1,6 @@
diff -ur pypy-2.5.0-src.orig/rpython/translator/platform/posix.py pypy-2.5.0-src/rpython/translator/platform/posix.py
---- rpython/translator/platform/posix.py 2015-02-03 05:12:49.000000000 +0800
-+++ rpython/translator/platform/posix.py 2015-03-22 07:36:01.420116684 +0800
+--- a/rpython/translator/platform/posix.py 2015-02-03 05:12:49.000000000 +0800
++++ b/rpython/translator/platform/posix.py 2015-03-22 07:36:01.420116684 +0800
@@ -183,7 +183,7 @@
'int main(int argc, char* argv[]) '
'{ return $(PYPY_MAIN_FUNCTION)(argc, argv); }" > $@')
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index de0ab069fb84..f22d4d75d875 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
# pypy3 needs to be built using python 2
PYTHON_COMPAT=( python2_7 pypy )
EHG_PROJECT="pypy"
EHG_REPO_URI="https://bitbucket.org/pypy/pypy"
EHG_REVISION="py3k"
-inherit check-reqs eutils mercurial multilib multiprocessing pax-utils \
+inherit check-reqs mercurial multiprocessing pax-utils \
python-any-r1 toolchain-funcs versionator
DESCRIPTION="A fast, compliant alternative implementation of the Python (3.3) language"
@@ -83,9 +83,9 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}/4.0.0-gentoo-path.patch" \
- "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch" \
- "${FILESDIR}"/2.5.0-shared-lib.patch # 517002
+ eapply "${FILESDIR}/4.0.0-gentoo-path.patch"
+ eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
+ eapply "${FILESDIR}"/2.5.0-shared-lib.patch # 517002
sed -e "s^@EPREFIX@^${EPREFIX}^" \
-e "s^@libdir@^$(get_libdir)^" \
@@ -93,10 +93,10 @@ src_prepare() {
# apply CPython stdlib patches
pushd lib-python/3 > /dev/null || die
- epatch "${FILESDIR}"/5.7.1_all_distutils_cxx.patch
+ eapply "${FILESDIR}"/5.7.1_all_distutils_cxx.patch
popd > /dev/null || die
- epatch_user
+ eapply_user
}
src_configure() {