summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyproj
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest2
-rw-r--r--dev-python/pyproj/metadata.xml10
-rw-r--r--dev-python/pyproj/pyproj-1.9.3-r1.ebuild24
-rw-r--r--dev-python/pyproj/pyproj-1.9.4.ebuild33
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
new file mode 100644
index 000000000000..856c3e70c254
--- /dev/null
+++ b/dev-python/pyproj/Manifest
@@ -0,0 +1,2 @@
+DIST pyproj-1.9.3.tar.gz 2687498 SHA256 912ed86c5e407f091d0f3d076594af4fb569e27c68199b7d71651edd522aaa0c SHA512 a365da012bf7b9adc8069896bdeabf88ff3d260b643e49b8a74edccc3b65aab10ec96116353fbb45c73ce1027c9b4e80aae566c6b28e149110b16cd8405cda30 WHIRLPOOL b6008b4879722e6e6ce82fbda22a5d8f57e6484f74d2607c19087130f833188ee76d1bc40ffd205babb25b9e7ea983c80bc1bd7555dd83f2473f2950421e7c62
+DIST pyproj-1.9.4.tar.gz 7838454 SHA256 71b4d8c52d781e2b4afe2d3609e9d700cb631ddbf51060bc702644733cc70869 SHA512 96b118e75ba8360ca56176631c44567c7b6596f98189a99bfbdc2d0f8bff1bba814a86d66ac1c54964951a3534c2a5cfb54a0fc4d8eda52c77069a8b64f8db3a WHIRLPOOL 750f466566aab3d2edb155407f37efc7f514901bd782b5be589f1c788059c81c8e17e519d53410be169cec971aa3524268bd86e08f9f90a1e2b742343f6b0ae2
diff --git a/dev-python/pyproj/metadata.xml b/dev-python/pyproj/metadata.xml
new file mode 100644
index 000000000000..60cafbbd17f0
--- /dev/null
+++ b/dev-python/pyproj/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="google-code">pyproj</remote-id>
+ <remote-id type="pypi">pyproj</remote-id>
+ <remote-id type="github">jswhit/pyproj</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyproj/pyproj-1.9.3-r1.ebuild b/dev-python/pyproj/pyproj-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..f563b867855b
--- /dev/null
+++ b/dev-python/pyproj/pyproj-1.9.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to PROJ.4 library"
+HOMEPAGE="http://code.google.com/p/pyproj/ http://pypi.python.org/pypi/pyproj"
+SRC_URI="http://pyproj.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyproj/pyproj-1.9.4.ebuild b/dev-python/pyproj/pyproj-1.9.4.ebuild
new file mode 100644
index 000000000000..a1e47073bfdc
--- /dev/null
+++ b/dev-python/pyproj/pyproj-1.9.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to PROJ.4 library"
+HOMEPAGE="http://github.com/jswhit/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+python_test() {
+ einfo "Testruns do not have regular unittest type tests, instead for test.py,"
+ einfo "the output need be compared with a separate file, sample.out."
+ "${PYTHON}" test/test.py || die
+
+ einfo ""; einfo "Now the file test2.py is run to test pickling"; einfo ""
+ "${PYTHON}" test/test2.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}