summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-01 21:41:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:41:49 +0300
commit1d1352bf7c6ca45e13b6a99759f4f3e765b5ce06 (patch)
tree7a868c30f40b09e7b2443b8617211b4b0c38d138 /dev-python/pyphen/pyphen-0.13.0.ebuild
parentapp-text/unpaper: Stabilize 7.0.0 x86, #867910 (diff)
downloadgentoo-1d1352bf7c6ca45e13b6a99759f4f3e765b5ce06.tar.gz
gentoo-1d1352bf7c6ca45e13b6a99759f4f3e765b5ce06.tar.bz2
gentoo-1d1352bf7c6ca45e13b6a99759f4f3e765b5ce06.zip
dev-python/pyphen: add 0.13.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyphen/pyphen-0.13.0.ebuild')
-rw-r--r--dev-python/pyphen/pyphen-0.13.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyphen/pyphen-0.13.0.ebuild b/dev-python/pyphen/pyphen-0.13.0.ebuild
new file mode 100644
index 000000000000..77020f6adc62
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.13.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+SRC_URI="https://github.com/Kozea/Pyphen/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # avoid dep on extra plugins
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}