summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-18 17:56:42 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-18 18:54:04 -0600
commitbbd43706e570192f2d9af3fb05a128e3bd1d2a7a (patch)
treea141f59dfcca8ab754134e9bda8aebef6b849e5b /dev-python/pyopenssl
parentdev-python/alembic: 0.9.7 bup (diff)
downloadgentoo-bbd43706e570192f2d9af3fb05a128e3bd1d2a7a.tar.gz
gentoo-bbd43706e570192f2d9af3fb05a128e3bd1d2a7a.tar.bz2
gentoo-bbd43706e570192f2d9af3fb05a128e3bd1d2a7a.zip
dev-python/pyopenssl: 17.5.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest1
-rw-r--r--dev-python/pyopenssl/pyopenssl-17.5.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index 9e343464a737..0879dca1b7d4 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -2,3 +2,4 @@ DIST pyOpenSSL-16.2.0.tar.gz 167305 BLAKE2B c6daa906695b57cd48153ad6e86ac1ca24f5
DIST pyOpenSSL-17.0.0.tar.gz 167121 BLAKE2B d3aa8713ecba18c6018e83b4da2de46ec8a0bb7bd24fa0b069c32f4ea75fde8aa371b9fa90625e536ea64cb9ee9c349d3c129988cdf495de8389707198248e43 SHA512 819be95f920a70b40ae48ed6740bd1d8cd3bf2fc080f682db8978946929994cb87ac467e220267dcdafc40aa7ed2cce51a334a49b06c1e2665d295157181ddad
DIST pyOpenSSL-17.2.0.tar.gz 170816 BLAKE2B 10abfa61ff329d23c99897c58a02a487c28d19ce7c5d312bd5c769473aea40d846c3b036d34d674e008d155e2be88e26190f19a890ee375893a08ecafe6afaf5 SHA512 aef1628665353445760a0c869c5b88ba1f61a3ade7471bfd1ad9e57672573501574dab5a2491aaac1dc283893fcac1a81dd9b972f43d53fe7ef1aa48e3f0e88a
DIST pyOpenSSL-17.4.0.tar.gz 169362 BLAKE2B 87a51efaa157b4a91a48edfcd9348402b6734e1c9f78e7ed638e3d245ae3922083c625e3d967e7513c588e131f96b06f110ae528cccbbb820f685afb9dda72ef SHA512 c3c791b15f2245d3c1381f84471f9e1b07b4a01c318a5a4012ec70193ba055fe948ba150f9c88d2dabe30b37f2025fe26ffb95c01682ca656d561014d41cf965
+DIST pyOpenSSL-17.5.0.tar.gz 170870 BLAKE2B e8b8986a7c5475ac3898df4877a8be86db359af79e1718bad85149440cff543c501ee23eb369270d2c539a9e3f4e13165ea87b858ef6916ee79ca6e49f6e5370 SHA512 f194662b5842f1e3a4fcb910b9f2e6482d1dcdf834f306acc3dd6d9723f65038f7bff550248fa6268d90c839c9d9e8248bb6c7d399495fe6aed25291b93ece86
diff --git a/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild b/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild
new file mode 100644
index 000000000000..c064b7937ada
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ http://pyopenssl.sourceforge.net/
+ https://launchpad.net/pyopenssl
+ https://pypi.python.org/pypi/pyOpenSSL
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ # Requires network access
+ sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}