summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2016-12-06 10:28:01 +0100
committerTobias Klausmann <klausman@gentoo.org>2016-12-06 10:29:05 +0100
commitda3ac2fc4ebd5399529b7728af6a1b4b5e2fad54 (patch)
treeb5564d3cb2b70d04e47a7179882c601b70a072a7 /dev-python/pynacl
parentmedia-video/snappy: Drop old (diff)
downloadgentoo-da3ac2fc4ebd5399529b7728af6a1b4b5e2fad54.tar.gz
gentoo-da3ac2fc4ebd5399529b7728af6a1b4b5e2fad54.tar.bz2
gentoo-da3ac2fc4ebd5399529b7728af6a1b4b5e2fad54.zip
dev-python/pynacl: Ensure that the bundled libsodium is never used
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/pynacl')
-rw-r--r--dev-python/pynacl/pynacl-1.0.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pynacl/pynacl-1.0.1-r1.ebuild b/dev-python/pynacl/pynacl-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..82dde1aaa2e4
--- /dev/null
+++ b/dev-python/pynacl/pynacl-1.0.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5})
+
+inherit distutils-r1
+
+MY_PN="PyNaCl"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
+HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.python.org/pypi/PyNaCl/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
+ dev-libs/libsodium:0/18
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}] )
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # For not using the bundled libsodium
+ export SODIUM_INSTALL=system
+ distutils-r1_python_prepare_all
+}