summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyminuit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyminuit')
-rw-r--r--dev-python/pyminuit/Manifest2
-rw-r--r--dev-python/pyminuit/metadata.xml8
-rw-r--r--dev-python/pyminuit/pyminuit-1.2.1.ebuild38
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyminuit/Manifest b/dev-python/pyminuit/Manifest
new file mode 100644
index 000000000000..ac6bea7915b1
--- /dev/null
+++ b/dev-python/pyminuit/Manifest
@@ -0,0 +1,2 @@
+DIST Minuit-1_7_9-patch1.tar.gz 430753 SHA256 3c223b0d145484bd8bff202f6c18efb974218130fa1ca49389db512d02bd58e4 SHA512 741ded2e6e999e8edf1e067ce9c2583784f6c1a7e34709430074d1f312de3a5815249466fe0a1c5be0a2f77932f34cbdb4bd1eb9de1b3528223711f26cbc65b9 WHIRLPOOL a6103d209cb8b97202346acd7ef0fdb37a0eb3a94658e6130ff8013448c5d56730ee3d8985c59f406cbd18e0fbb4586b443fe93a4b3c95bc0e0c9621cd5a09ee
+DIST pyminuit-1.2.1.tgz 17099 SHA256 d065f7f57a524ec322cb95252a6ed6e8056148f0d34fd90ae2bfc1259ac4d4ea SHA512 b5bd954288d57a6c043e336ddb62a42cd4e6cc340847fbd700573db288c4404ef80a86a76b3c4e458913cd73b08ea97b20a4e411043a6ce826d9d88ee54fbe1f WHIRLPOOL 28e84ddd1125e76365cb204079281f184e89ed8033b8535c399ac422c5f02a4c7dc2ac34c488fa8a86557d3bab44b3d4ca72c00890c89fc91adb2f5275c0e6a7
diff --git a/dev-python/pyminuit/metadata.xml b/dev-python/pyminuit/metadata.xml
new file mode 100644
index 000000000000..7bc6ee8ea837
--- /dev/null
+++ b/dev-python/pyminuit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyminuit/pyminuit-1.2.1.ebuild b/dev-python/pyminuit/pyminuit-1.2.1.ebuild
new file mode 100644
index 000000000000..c8b4920cf29d
--- /dev/null
+++ b/dev-python/pyminuit/pyminuit-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Minuit numerical function minimization in Python"
+HOMEPAGE="https://code.google.com/p/pyminuit"
+SRC_URI="
+ https://pyminuit.googlecode.com/files/${P}.tgz
+ https://pyminuit.googlecode.com/files/Minuit-1_7_9-patch1.tar.gz
+ "
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+src_configure() {
+ cd "${WORKDIR}"/Minuit-1_7_9 && econf --disable-static || die
+}
+src_compile() {
+ cd "${WORKDIR}"/Minuit-1_7_9 && emake
+ cd "${S}"
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ cd "${WORKDIR}"/Minuit-1_7_9 || die
+ default
+ distutils-r1_python_install_all
+}