summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-21 10:57:37 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-21 11:01:54 +0100
commit2e8180b629066649ad41d15f3d357288855f6efb (patch)
tree1de8ef55f2b2cb45e7e3258423a35098d9f0e59c /dev-python/pymilter/pymilter-1.0.4-r2.ebuild
parentapp-backup/bareos: add 19.2.12, drop 19.2.11-r1 (diff)
downloadgentoo-2e8180b629066649ad41d15f3d357288855f6efb.tar.gz
gentoo-2e8180b629066649ad41d15f3d357288855f6efb.tar.bz2
gentoo-2e8180b629066649ad41d15f3d357288855f6efb.zip
dev-python/pymilter: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pymilter/pymilter-1.0.4-r2.ebuild')
-rw-r--r--dev-python/pymilter/pymilter-1.0.4-r2.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/pymilter/pymilter-1.0.4-r2.ebuild b/dev-python/pymilter/pymilter-1.0.4-r2.ebuild
index 7e176d188aa8..4df4b583f2ea 100644
--- a/dev-python/pymilter/pymilter-1.0.4-r2.ebuild
+++ b/dev-python/pymilter/pymilter-1.0.4-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -17,9 +17,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64"
-RDEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ || (
+ mail-filter/libmilter
+ mail-mta/sendmail
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
BDEPEND="
- test? ( $(python_gen_impl_dep sqlite) )"
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
distutils_enable_tests unittest