summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-19 12:46:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-19 12:48:53 +0200
commitdfcc941de3a9f04c7f6b9aed88d6e97fdfafc789 (patch)
tree99ee47c6ba4bed657a2be8fafe9854372cb4bb50 /dev-python/pylev
parentdev-python/clikit: Fix test failures (diff)
downloadgentoo-dfcc941de3a9f04c7f6b9aed88d6e97fdfafc789.tar.gz
gentoo-dfcc941de3a9f04c7f6b9aed88d6e97fdfafc789.tar.bz2
gentoo-dfcc941de3a9f04c7f6b9aed88d6e97fdfafc789.zip
dev-python/pylev: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylev')
-rw-r--r--dev-python/pylev/Manifest1
-rw-r--r--dev-python/pylev/pylev-1.4.0-r1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pylev/Manifest b/dev-python/pylev/Manifest
index 9add27a3a01c..fba4b3fc7099 100644
--- a/dev-python/pylev/Manifest
+++ b/dev-python/pylev/Manifest
@@ -1 +1,2 @@
+DIST pylev-1.4.0.gh.tar.gz 4895 BLAKE2B d49e153d308165dcdc06bad94013afa4ccc6d2a6ecff943a2718a8f9ab71bbacb9c0cf8b604dbf0c77322a8d0cbeba5ffaed13531a31210507f144f716f8e740 SHA512 3999adf04b159499a199b1aa66e2540904c689c50a407bf7e0cc0affe834ea289006d2fc73f65e4fcd486c755c580e9657dc5c67290dccb4704bebc6a4348de3
DIST pylev-1.4.0.tar.gz 4895 BLAKE2B d49e153d308165dcdc06bad94013afa4ccc6d2a6ecff943a2718a8f9ab71bbacb9c0cf8b604dbf0c77322a8d0cbeba5ffaed13531a31210507f144f716f8e740 SHA512 3999adf04b159499a199b1aa66e2540904c689c50a407bf7e0cc0affe834ea289006d2fc73f65e4fcd486c755c580e9657dc5c67290dccb4704bebc6a4348de3
diff --git a/dev-python/pylev/pylev-1.4.0-r1.ebuild b/dev-python/pylev/pylev-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..0baaed9b640d
--- /dev/null
+++ b/dev-python/pylev/pylev-1.4.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Levenshtein implementation"
+HOMEPAGE="
+ https://github.com/toastdriven/pylev/
+ https://pypi.org/project/pylev/
+"
+SRC_URI="
+ https://github.com/toastdriven/pylev/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests unittest