summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-30 19:09:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-30 19:46:26 +0100
commit899c56fc5ffdbab50d184185414e7a2f3b37b2e1 (patch)
tree0e5e5f3c4cd45ae8230f0404e1042b0cf9766b90 /dev-python/pylast
parentprofiles: Add missing kde-apps/kdenlive 21.12 RC to package.mask (diff)
downloadgentoo-899c56fc5ffdbab50d184185414e7a2f3b37b2e1.tar.gz
gentoo-899c56fc5ffdbab50d184185414e7a2f3b37b2e1.tar.bz2
gentoo-899c56fc5ffdbab50d184185414e7a2f3b37b2e1.zip
dev-python/pylast: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-4.4.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 030265c96299..df9cdfec11da 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,2 +1,3 @@
DIST pylast-4.2.1.tar.gz 39787 BLAKE2B 1f2f06671ce38bd42f7297279a58f674c3af8f66de4fe804d90e3fc178c73f09a24f65bbc4fd534da0c04f593dc5eb31f03da38a4ca969ea31a04978a603b7b4 SHA512 c1418ff1e6b6ab905d790cc83eb1a4b3172c0c28d523c2bbd641523a2e2601a84aff126dafd047f0fb9b82744bca883648e197b273026611f47671d39afd4fc6
DIST pylast-4.3.0.tar.gz 39875 BLAKE2B 9b51c44295babc54207593e43d70ec121ddc4c4e5bea8a0936691d02c2cf996869cc3995f5b069bfe3a9208754705a716716cb6bb8aefef142723687dc07a16a SHA512 2880e142da2841775f2c48f2d5ad0adc39e6b65073a76dd6af24c65f420948755b25f7a630b95315ffbdd1f7536d9ac4570b3df01d6837f77faccf89aaf41f33
+DIST pylast-4.4.0.tar.gz 39793 BLAKE2B 13a2bd4652b0dee142442f8bc6bf922f544b093be207efe8661f5355e37ff59a5c0d9c844193d2d3e4f22ccafc10993b8cced6872d4f0fece42c37524bee8beb SHA512 341b3f8a6691699b9581769d1f06908df8ec694a22d8918e4ed37af1f47287577c5fc156f3807c744aa9774d69e23570036f06a8e9921f3c7c7d21b53b8eb041
diff --git a/dev-python/pylast/pylast-4.4.0.ebuild b/dev-python/pylast/pylast-4.4.0.ebuild
new file mode 100644
index 000000000000..128111781b3b
--- /dev/null
+++ b/dev-python/pylast/pylast-4.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}