summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-18 06:19:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-18 06:19:46 +0100
commit7c5c545c6a63ae84ef01eafa0e3c64677dbaa00d (patch)
tree9ea10ba75b3df8fdde44a07b138def977bef37b1 /dev-python/pyjwt
parentdev-python/setproctitle: Bump to 1.3.4 (diff)
downloadgentoo-7c5c545c6a63ae84ef01eafa0e3c64677dbaa00d.tar.gz
gentoo-7c5c545c6a63ae84ef01eafa0e3c64677dbaa00d.tar.bz2
gentoo-7c5c545c6a63ae84ef01eafa0e3c64677dbaa00d.zip
dev-python/pyjwt: Bump to 2.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest1
-rw-r--r--dev-python/pyjwt/pyjwt-2.10.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 557ad3b0b719..1192827d1e2d 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1 +1,2 @@
+DIST pyjwt-2.10.0.tar.gz 87687 BLAKE2B c3595b24bab66db56d6140e791c5326200dccf65499e7fc11f0448ff9a0189d3b309b33afba96e52eb1147ccda317137530650ef70d765a7e75d3b453f1a71f8 SHA512 3390e4613718e6fffe0a589a2b9f35ac8d29a12a7059d15281496c9a45b8e52b2ca165e3e7ba66bc2683d5df8d1ae8ed726bcc6e3afc0421a17491afe263f2b7
DIST pyjwt-2.9.0.tar.gz 78825 BLAKE2B f8228502944e6fc50412533c0c3f6d03fe7538dae8e1c42dd01d6b4419ef165f98125712e48d5c5b7f0d7eced36b6a84a69b9da549fe5e57effcba652f78faec SHA512 10d0344e05a142b3edadc970dd5cebc5eada1f638a599ca0f566c00149d67626c7fa1bbe668a56bc93048669df3af266c581f4872bf5756a4cc526f4b831dfc1
diff --git a/dev-python/pyjwt/pyjwt-2.10.0.ebuild b/dev-python/pyjwt/pyjwt-2.10.0.ebuild
new file mode 100644
index 000000000000..a9b4a5316dcf
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="PyJWT"
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="
+ https://github.com/jpadilla/pyjwt/
+ https://pypi.org/project/PyJWT/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ !dev-python/python-jwt
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_jwks_client.py::TestPyJWKClient::test_get_jwt_set_sslcontext_default
+)
+
+pkg_postinst() {
+ optfeature "cryptography" dev-python/cryptography
+}