summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-01-20 10:33:42 -0800
committerPatrick McLean <chutzpah@gentoo.org>2023-01-20 10:38:31 -0800
commitce5b6b174eca71d8b2f2ea7c1eb9715027076514 (patch)
tree631b55460fdebad38c5c40d44e1c3df651a5275a /dev-python/pyhcl
parentwww-client/chromium: bump patchset for beta channel (diff)
downloadgentoo-ce5b6b174eca71d8b2f2ea7c1eb9715027076514.tar.gz
gentoo-ce5b6b174eca71d8b2f2ea7c1eb9715027076514.tar.bz2
gentoo-ce5b6b174eca71d8b2f2ea7c1eb9715027076514.zip
dev-python/pyhcl: Fix version (bugs 891339, 798378), eapi8, py311
Closes: https://bugs.gentoo.org/891339 Closes: https://bugs.gentoo.org/798378 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pyhcl')
-rw-r--r--dev-python/pyhcl/Manifest2
-rw-r--r--dev-python/pyhcl/pyhcl-0.4.4-r1.ebuild (renamed from dev-python/pyhcl/pyhcl-0.4.4.ebuild)14
2 files changed, 7 insertions, 9 deletions
diff --git a/dev-python/pyhcl/Manifest b/dev-python/pyhcl/Manifest
index c976ce60a37a..06f3a804c010 100644
--- a/dev-python/pyhcl/Manifest
+++ b/dev-python/pyhcl/Manifest
@@ -1 +1 @@
-DIST pyhcl-0.4.4.tar.gz 58400 BLAKE2B 89ce8ba1eff577d9b4c7a86931e305f94ad7633b83c27f44352658ec2a12e48fd0cb05619e4afd97e4f2d78a9f4dba5c082a0d5703060b629880a3d193d9b4ee SHA512 7c5e2b611d1198a0e6c667b8fda868231bdd25da822d634a34c076fea655a7ea2999fc827de8484992efcf52b6b843871713a83e3be7787003c90f05e3e7ddf6
+DIST pyhcl-0.4.4.gh.tar.gz 58400 BLAKE2B 89ce8ba1eff577d9b4c7a86931e305f94ad7633b83c27f44352658ec2a12e48fd0cb05619e4afd97e4f2d78a9f4dba5c082a0d5703060b629880a3d193d9b4ee SHA512 7c5e2b611d1198a0e6c667b8fda868231bdd25da822d634a34c076fea655a7ea2999fc827de8484992efcf52b6b843871713a83e3be7787003c90f05e3e7ddf6
diff --git a/dev-python/pyhcl/pyhcl-0.4.4.ebuild b/dev-python/pyhcl/pyhcl-0.4.4-r1.ebuild
index dac65ed9f6f3..c7c457c0ad35 100644
--- a/dev-python/pyhcl/pyhcl-0.4.4.ebuild
+++ b/dev-python/pyhcl/pyhcl-0.4.4-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-# This value is obtained by running the following on the checked out
-# tag:
-# git describe --tags --long
-LONG_VERSION=0.4.4-0-g314cd32
-PYTHON_COMPAT=( python3_{9..10} )
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="HCL configuration parser for python"
@@ -16,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/virtuald/pyhcl.git"
else
- SRC_URI="https://github.com/virtuald/pyhcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/virtuald/pyhcl/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64 ~arm64"
fi
@@ -26,6 +24,6 @@ SLOT="0"
distutils_enable_tests pytest
python_prepare_all() {
+ printf '__version__ = "%s"\n' "${PV}" > src/hcl/version.py || die
distutils-r1_python_prepare_all
- printf '__version__ = "%s"\n' "${LONG_VERSION}" > src/hcl/version.py || die
}