summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-27 13:01:24 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-27 13:08:17 +0100
commitf4d2d19a7272421b673605509a66011cb4fd0c86 (patch)
tree06ef092ea5d77bc01136816463173f55bdeb8ed6 /dev-python/pygit2
parentsci-electronics/ngspice: bump to version 27 and EAPI 6 (diff)
downloadgentoo-f4d2d19a7272421b673605509a66011cb4fd0c86.tar.gz
gentoo-f4d2d19a7272421b673605509a66011cb4fd0c86.tar.bz2
gentoo-f4d2d19a7272421b673605509a66011cb4fd0c86.zip
dev-python/pygit2: Bump to 0.26.3
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-0.26.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index c893d466aa64..4a68d814e3a3 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -2,3 +2,4 @@ DIST pygit2-0.25.0.tar.gz 472116 BLAKE2B 5d3f487d99bf9cccf5ff646d011963d61e3b583
DIST pygit2-0.25.1.tar.gz 456580 BLAKE2B b7a9ce90076f2475df41f2e5ee8cbf7cb2ca68553076ae05cb2e8bdd68067f7373e33dfb03cadf90b7f410b5d5989b902b545fddbb1e3a9f17eb17d50692e982 SHA512 19908c874d5c2469609a54893f37367480d27ff03583c38b474ebb125dc9db95dc60776a120bb05662938d6eb62d4bcef24f684688e97e3453ccc27e015736cd
DIST pygit2-0.26.0.tar.gz 457263 BLAKE2B 76469a53a529fb6dcc12da952821edf9fbb100d6043371748e493de9d453866adb1a790ec7f996eefe588db1a32faa66e9deb05eda20abee815cc85bcc616eb9 SHA512 e8626712a3b75aced14997dda0155f5c7be9a7e0e43aeb2c767c848fcbe711780137f663cc9ad5268cd85e2c61fd40be6853573f68b457cd5d46d6c32a644076
DIST pygit2-0.26.1.tar.gz 458526 BLAKE2B 703093a5a292e92c90987785065f3a1590addc09d72311f75b22caf6fe1a17be8fb16cf777189835204cb7dc4d2066e841d3d4327e2cc040c312e22a4c75a8ee SHA512 23585bc0f41458442889b5434347cbc11d6c729898864262426f84e5b9239164bb58c6e910d2381b25f1b8be271674c1a6960630a504c40accdd30e487d27a7d
+DIST pygit2-0.26.3.tar.gz 462080 BLAKE2B b3c4b9b8a6aeba22a70a8d2ef1393dace3a065a3625ee3574058e333bca4ba1d60223939f412eecf5ae9d93a81fb81c4a536af46aa047c2c82a48bd81afe4cf9 SHA512 6f727686221d4e8c348f836b7ad278b48a4b971a121b9953c2cf7163bf093936d838aaf83e9edb8628757624ab27e8345a2fb29eb1a79a30e06c0ab0a77e4cc6
diff --git a/dev-python/pygit2/pygit2-0.26.3.ebuild b/dev-python/pygit2/pygit2-0.26.3.ebuild
new file mode 100644
index 000000000000..145de65074a1
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.26.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 eapi7-ver
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.python.org/pypi/pygit2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(ver_cut 1-2)*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test --args='-v'
+}