summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-11 16:05:05 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-11 16:17:29 +0100
commit7d983af11f28f1d061719a6f137a2cd2656ee066 (patch)
tree524db5c9a455f50a7c8c2f167ece72ad48f16e52 /dev-python/pygit2
parentx11-misc/sxhkd: Add myself as maintainer (diff)
downloadgentoo-7d983af11f28f1d061719a6f137a2cd2656ee066.tar.gz
gentoo-7d983af11f28f1d061719a6f137a2cd2656ee066.tar.bz2
gentoo-7d983af11f28f1d061719a6f137a2cd2656ee066.zip
dev-python/pygit2: Bump to 1.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.0.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 6e8da0e7e973..31e37ad20982 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,2 +1,3 @@
DIST pygit2-0.28.2.tar.gz 496469 BLAKE2B 1173401d4555f6f40eaf5a27d9c0e83214b66afa609f15cc4d689e8c58cc0ae3865b4e6ebb31808d354ecef56f3a74cc777fe42314ef348c39f1f61d82655bc9 SHA512 3f742cdcc9d603c9cc9ef2e0a545da8bcfb555a0bdeea1c73c53a284b43d40ad6b28c87a029578ad7b1c8f2bf56ecd2859dac8dd836474bfc66223ff4af9e8f0
DIST pygit2-1.0.1.tar.gz 501496 BLAKE2B 6a844a6ecab453f589f407acbd94aba46018a46374ba745ef50e72f4a5eda35103873287af7533ec963a297775eb3703151beec36984dfbcb68d751057c46c78 SHA512 c225204129cdfa41bcc50d76ff219602bfe910cdb77e246c49ecf5265b5a88c5c4803a7d107f4e00c4ec2f0b0d30e1a729d15413bdca8575d6ec23bb9420a90d
+DIST pygit2-1.0.2.tar.gz 501736 BLAKE2B c8f1a7e4a3257af42d97b0fae8e14f26968e2be535e74863c97363e77e37774d929fa239bbb46982bd398a3c2032f3b3122bd42aa41760d3827a18b7b0b22663 SHA512 c76bf8ce2847ec8915201a714f076488a0dda4a790762293c02709b8b88a9a2b898f97e61565cf41cd11b10bebe2e1d76b5643ff2e86f9bf6a9517c87a988769
diff --git a/dev-python/pygit2/pygit2-1.0.2.ebuild b/dev-python/pygit2/pygit2-1.0.2.ebuild
new file mode 100644
index 000000000000..920c961be99e
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-libs/libgit2-0.28*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/def no_network/a \
+ return True' test/utils.py || die
+
+ # we need to move them away to prevent pytest from forcing '..'
+ # for imports
+ mkdir hack || die
+ mv test hack/ || die
+ ln -s hack/test test || die
+}
+
+python_test() {
+ pytest -vv hack/test || die
+}