summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-13 07:22:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-13 07:30:12 +0200
commita9dbd2e849b6c7235263993a58a6bb9946a5bee6 (patch)
tree22a6ed1b9d24b7d36463f92f83f6975e9c0a172b /dev-python/pyghmi
parentdev-python/mdurl: Bump to 0.1.1 (diff)
downloadgentoo-a9dbd2e849b6c7235263993a58a6bb9946a5bee6.tar.gz
gentoo-a9dbd2e849b6c7235263993a58a6bb9946a5bee6.tar.bz2
gentoo-a9dbd2e849b6c7235263993a58a6bb9946a5bee6.zip
dev-python/pyghmi: Bump to 1.5.37
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/metadata.xml1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.37.ebuild39
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 9f78e3b3ac8e..a03da063ec3a 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -4,3 +4,4 @@ DIST pyghmi-1.5.32.tar.gz 236662 BLAKE2B e2a58d1eb9c5000d1a7f6b795836fa617ac0847
DIST pyghmi-1.5.33.tar.gz 237980 BLAKE2B 3599c0f56b665129e0432faa9aaab8fdbc831ec8398a3eea2034e68cbf1f75638ecad7ce7ae4e7ac0d51a4a7ac502837da8d3c421e836c88214d82ed7d0bc901 SHA512 1e187f5824491e9d4f48c2f0a5578ced6916764b6bc4f442045e34f37bff85bf16e3ab88df29f8797b15293282112aa04e2f0a375498e96c8aa7b3c7005d22dc
DIST pyghmi-1.5.34.tar.gz 239758 BLAKE2B 3347498d7c1dc0eed102569cc7bc7c2084c694853a5e33c4145dadf623dc9a3db398fa32dc8fc87717a1df2db15c0477cbf59b1eba4c23cf558b45abbf47308e SHA512 fc61d5f8814366e51964b30e29f632d774ec8f202e4c05bd973fbe74e11f560a706e4abd6e01e4ae52d72dff2608c6abe72b5c46941884e472f159d2e4063047
DIST pyghmi-1.5.36.tar.gz 240917 BLAKE2B 69e7f990c97a889d90e06feeb1b7b3fc73d6441cfe8ba7a22e0aa0e2b3553afb5166fb732699718dad04592aca95b8aaf28943ed92de136e45f381094b7c97af SHA512 b5536cf1c48929cb8acc7c9f77c09d0d51456cdfb2f74346387a483661332cdc02a614eac633a3e9aeabfac48b1a25a627668660be167fbf07b96c090ac6e197
+DIST pyghmi-1.5.37.tar.gz 241173 BLAKE2B 7094150c6002b59e1fcd9b337987d3506928222d55195c024027d31d281e5074210dac91c64853bbaac628dc112b9c4081a7193146927112dcc987f789faa018 SHA512 e70894f6e63afadc68bae88ebd8ff1f63904106db86b582b547a6f1eb7acde903352f08ffc62d7915e2baa45507f70331a6dc9f6b0dcd471fd330e39a69d064f
diff --git a/dev-python/pyghmi/metadata.xml b/dev-python/pyghmi/metadata.xml
index bd120511a5a3..ff52f353b641 100644
--- a/dev-python/pyghmi/metadata.xml
+++ b/dev-python/pyghmi/metadata.xml
@@ -8,6 +8,5 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">pyghmi</remote-id>
- <remote-id type="github">openstack-archive/pyghmi</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pyghmi/pyghmi-1.5.37.ebuild b/dev-python/pyghmi/pyghmi-1.5.37.ebuild
new file mode 100644
index 000000000000..1844c945d4be
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.37.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest