summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Zuber <a.zuber@gmx.ch>2021-03-17 11:58:41 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-05-18 23:27:34 +0200
commit0c3e9e0342fe37d89baf01af7cd7effb9fdd6f0f (patch)
tree0df4e6bf3bf675ba2d690cc3713a994566f64f07 /dev-python/pygal
parentdev-python/PyRSS2Gen: add Python 3.9 support (diff)
downloadgentoo-0c3e9e0342fe37d89baf01af7cd7effb9fdd6f0f.tar.gz
gentoo-0c3e9e0342fe37d89baf01af7cd7effb9fdd6f0f.tar.bz2
gentoo-0c3e9e0342fe37d89baf01af7cd7effb9fdd6f0f.zip
dev-python/pygal: python 3.9 and tests fix
Closes: https://bugs.gentoo.org/738208 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andreas Zuber <a.zuber@gmx.ch> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/pygal')
-rw-r--r--dev-python/pygal/files/2.4.0-fix-tests.patch17
-rw-r--r--dev-python/pygal/pygal-2.4.0-r2.ebuild (renamed from dev-python/pygal/pygal-2.4.0-r1.ebuild)6
2 files changed, 21 insertions, 2 deletions
diff --git a/dev-python/pygal/files/2.4.0-fix-tests.patch b/dev-python/pygal/files/2.4.0-fix-tests.patch
new file mode 100644
index 000000000000..6ae07df3427b
--- /dev/null
+++ b/dev-python/pygal/files/2.4.0-fix-tests.patch
@@ -0,0 +1,17 @@
+diff --git a/pygal/test/conftest.py b/pygal/test/conftest.py
+index ea36010..6fe40cb 100644
+--- a/pygal/test/conftest.py
++++ b/pygal/test/conftest.py
+@@ -48,9 +48,9 @@ def pytest_generate_tests(metafunc):
+ if hasattr(sys, 'pypy_version_info'):
+ etree.to_etree()
+
+- if "Chart" in metafunc.funcargnames:
++ if "Chart" in metafunc.fixturenames:
+ metafunc.parametrize("Chart", pygal.CHARTS)
+- if "datas" in metafunc.funcargnames:
++ if "datas" in metafunc.fixturenames:
+ metafunc.parametrize(
+ "datas", [[("Serie %d" % i, get_data(i)) for i in range(s)]
+ for s in (5, 1, 0)]
+--
diff --git a/dev-python/pygal/pygal-2.4.0-r1.ebuild b/dev-python/pygal/pygal-2.4.0-r2.ebuild
index d99f0e5a873f..b886f7767a65 100644
--- a/dev-python/pygal/pygal-2.4.0-r1.ebuild
+++ b/dev-python/pygal/pygal-2.4.0-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1
@@ -29,6 +29,8 @@ BDEPEND="
)
"
+PATCHES=( "${FILESDIR}/${PV}-fix-tests.patch" )
+
# CHANGELOG is a symlink to docs/changelog.rst
DOCS=( docs/changelog.rst README.md )