summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec dolsen <dolsen@gentoo.org>2018-07-21 13:12:05 -0700
committerBrian Dolbec dolsen <dolsen@gentoo.org>2018-07-21 13:26:13 -0700
commitb329d245898fc62a613810788db9440f7bc0fd04 (patch)
treea39b8618262316761d5b8ad0fa278d259f517f13 /dev-python/pydecomp
parentprofiles/../s390/p.u/mask: mask dev-util/ninja[zsh-completion] (diff)
downloadgentoo-b329d245898fc62a613810788db9440f7bc0fd04.tar.gz
gentoo-b329d245898fc62a613810788db9440f7bc0fd04.tar.bz2
gentoo-b329d245898fc62a613810788db9440f7bc0fd04.zip
dev-python/pydecomp: Version and eapi bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/pydecomp')
-rw-r--r--dev-python/pydecomp/Manifest1
-rw-r--r--dev-python/pydecomp/pydecomp-0.3.ebuild36
-rw-r--r--dev-python/pydecomp/pydecomp-9999.ebuild4
3 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/pydecomp/Manifest b/dev-python/pydecomp/Manifest
index 846962830984..8c53d5b30aad 100644
--- a/dev-python/pydecomp/Manifest
+++ b/dev-python/pydecomp/Manifest
@@ -1 +1,2 @@
DIST pydecomp-0.2.tar.gz 9819 BLAKE2B fc2078b00f152e598599b1fc4b1239035d1d21789689fb49605a4c3afb6d9201a1b1635d6f1971edf98fef8de02caeb6ea5e6bae1fe2b21f546e8a712ca94949 SHA512 1cec8ba501cf6223740c50751508a83f474a9acbce811c82f6d8beb5536ea8ce9c1d04a218503acd13b6eec8d9a68ef4b712049a7e0ae94ff34ba05c6f50ebc9
+DIST pydecomp-0.3.tar.gz 10009 BLAKE2B 2741dc776ac265a84daf4c68542e652c7e2663dff1561297057f3ac219805136ece32af3f33e0b03df0a9883663692fc3855490478c538a0edec838c90c1c4b6 SHA512 7935111f9d0629eb74f529a6427b9db3cac4c9c205f80b28380ab9c323ca9ad7b78b40f69a7760a5a69ed065e9d6ddd42d08fb8f2cb787f15d2ec6e88e20221a
diff --git a/dev-python/pydecomp/pydecomp-0.3.ebuild b/dev-python/pydecomp/pydecomp-0.3.ebuild
new file mode 100644
index 000000000000..415930a122d4
--- /dev/null
+++ b/dev-python/pydecomp/pydecomp-0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 python-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://github.com/dol-sen/pyDeComp.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+ S="${WORKDIR}/pyDeComp-${PV}"
+fi
+
+DESCRIPTION="A python library of common (de)compression and contents handling"
+HOMEPAGE="https://github.com/dol-sen/pyDeComp"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyDeComp/issues"
+ einfo "I am also on IRC @ #gentoo-releng of the freenode network"
+}
diff --git a/dev-python/pydecomp/pydecomp-9999.ebuild b/dev-python/pydecomp/pydecomp-9999.ebuild
index c25e7e24119c..a7c9cb463406 100644
--- a/dev-python/pydecomp/pydecomp-9999.ebuild
+++ b/dev-python/pydecomp/pydecomp-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )