summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-27 07:50:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-27 07:55:05 +0200
commit10bc81be806dc626ac31707cae3a16c155de7607 (patch)
tree3cb183219e87ebe98e765995b45794c81ad2d692 /dev-python/pycurl
parentdev-python/pycurl: add patch for multiple SSL backends (diff)
downloadgentoo-10bc81be806dc626ac31707cae3a16c155de7607.tar.gz
gentoo-10bc81be806dc626ac31707cae3a16c155de7607.tar.bz2
gentoo-10bc81be806dc626ac31707cae3a16c155de7607.zip
dev-python/pycurl: Hack the version to make upgrade less painful
Change the version number so that egg path changes and avoids collisions while switching from setuptools to distutils. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.5-r1.ebuild3
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.5.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/pycurl/pycurl-7.43.0.5-r1.ebuild b/dev-python/pycurl/pycurl-7.43.0.5-r1.ebuild
index 1b678aa041e9..e5a319f2804a 100644
--- a/dev-python/pycurl/pycurl-7.43.0.5-r1.ebuild
+++ b/dev-python/pycurl/pycurl-7.43.0.5-r1.ebuild
@@ -60,6 +60,9 @@ python_prepare_all() {
sed -e 's:import wheel:raise ImportError:' -i setup.py || die
# these tests are broken with newer versions of bottle
sed -e 's:test.*_invalid_utf8:_&:' -i tests/getinfo_test.py || die
+ # temporary hack to make setuptools->distutils change less painful
+ # (suggested by Arfrever)
+ sed -e "/VERSION/s:${PV}:&.0:" -i setup.py || die
distutils-r1_python_prepare_all
}
diff --git a/dev-python/pycurl/pycurl-7.43.0.5.ebuild b/dev-python/pycurl/pycurl-7.43.0.5.ebuild
index 208be0af1b8f..321f11ec05b7 100644
--- a/dev-python/pycurl/pycurl-7.43.0.5.ebuild
+++ b/dev-python/pycurl/pycurl-7.43.0.5.ebuild
@@ -59,6 +59,9 @@ python_prepare_all() {
sed -e 's:import wheel:raise ImportError:' -i setup.py || die
# these tests are broken with newer versions of bottle
sed -e 's:test.*_invalid_utf8:_&:' -i tests/getinfo_test.py || die
+ # temporary hack to make setuptools->distutils change less painful
+ # (suggested by Arfrever)
+ sed -e "/VERSION/s:${PV}:&.0:" -i setup.py || die
distutils-r1_python_prepare_all
}