summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2019-12-05 00:53:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-08 19:27:38 +0100
commit450571447e3002e8d9f3388124d357b3ba943269 (patch)
tree34d01b4ab411f7b3fe6a467f8228fb58e594854a /dev-python/pycdio
parentsys-auth/sssd: Version bump (v2.2.3) (diff)
downloadgentoo-450571447e3002e8d9f3388124d357b3ba943269.tar.gz
gentoo-450571447e3002e8d9f3388124d357b3ba943269.tar.bz2
gentoo-450571447e3002e8d9f3388124d357b3ba943269.zip
dev-python/pycdio: bump version to 2.1.0
Closes: https://bugs.gentoo.org/701998 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/13873 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/Manifest1
-rw-r--r--dev-python/pycdio/pycdio-2.1.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pycdio/Manifest b/dev-python/pycdio/Manifest
index 423ecc934cb7..6cfe1b0d2369 100644
--- a/dev-python/pycdio/Manifest
+++ b/dev-python/pycdio/Manifest
@@ -1,2 +1,3 @@
DIST pycdio-0.20.tar.gz 197736 BLAKE2B 98ca603dba80a13dc3d1805869e190b9defa1a5c50b398ac4c7122629101df92ca8ad0071101bd8d53cbf48f41211017350a89944944028052899911b32d54e8 SHA512 b53a535440008dc637b31fd2cda22845c91b98e78c30f90c866af3b9bf7cb3faad39f0784b5063a39bd97bb18fc58c75ad0833d53421182d408c2889c491846b
DIST pycdio-2.0.0.tar.gz 242131 BLAKE2B cbe014ea42ecf2b84f736d4b714f0fa76c94b10e0b16da148334521ac4a141db606793be541ee532b7542e58256377bbc6139945232942ef2ef0beeda4b66ef5 SHA512 b73d49e143e4b5ebf5e8514d526a57f71d004b9ce4298743bb109902ee9551fa586384a236b26da9cd86284b2aa8c31fb02a324a1cebc03f2071d06fbd3e3285
+DIST pycdio-2.1.0.tar.gz 241434 BLAKE2B eb981fdf52b205e14c6dd353ac4aca9a9e82dba6967a53b9059f8a265ef80832fe7236d68b2af7a6e408665fce0f5ed3541289e0b7d282834c4feb8e6b428fc4 SHA512 dc18fbd212f7040b8b06efaf263b17568e9c2d089cff7dfc4dda50a7225059e44c9c86e2d81ade92cf09c823f7189b5723fb601cb12f0884dc04e9f5418c5927
diff --git a/dev-python/pycdio/pycdio-2.1.0.ebuild b/dev-python/pycdio/pycdio-2.1.0.ebuild
new file mode 100644
index 000000000000..0b249b5bcee0
--- /dev/null
+++ b/dev-python/pycdio/pycdio-2.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
+HOMEPAGE="https://savannah.gnu.org/projects/libcdio/ https://pypi.org/project/pycdio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/libcdio-2.0.0"
+
+BDEPEND="dev-lang/swig"
+
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # Remove obsolete sys.path and adjust 'data' paths in examples.
+ sed -i \
+ -e "s:^sys.path.insert.*::" \
+ -e "s:\.\./data:./data:g" \
+ example/*.py || die
+
+ # Disable failing tests.
+ sed -i -e "s/test_get_set/_&/" test/test-cdtext.py || die
+ sed -i -e "s/test_fs/_&/" test/test-isocopy.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all(){
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}