summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-02-28 20:03:44 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-02-28 20:16:25 +0200
commit8d0f85227354ea653ea8f723a9b2e1d9796ff3ae (patch)
treec8da4793e2c8b80467196325cf64b681eb764c9a /dev-python/prompt-toolkit
parentdev-python/ipython: add 8.11.0 (diff)
downloadgentoo-8d0f85227354ea653ea8f723a9b2e1d9796ff3ae.tar.gz
gentoo-8d0f85227354ea653ea8f723a9b2e1d9796ff3ae.tar.bz2
gentoo-8d0f85227354ea653ea8f723a9b2e1d9796ff3ae.zip
dev-python/prompt-toolkit: add 3.0.38
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/prompt-toolkit')
-rw-r--r--dev-python/prompt-toolkit/Manifest1
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.38.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/Manifest b/dev-python/prompt-toolkit/Manifest
index dc82e5ed2afc..cd3ae71a5d89 100644
--- a/dev-python/prompt-toolkit/Manifest
+++ b/dev-python/prompt-toolkit/Manifest
@@ -1,2 +1,3 @@
DIST prompt_toolkit-3.0.36.tar.gz 423863 BLAKE2B 1917ba618e4111f3d2d85f1063e3e34bc47cc1f60e1703be54cf92b98f72eb3cb3062381e16fd324953435ed67ce0711274f6d8faf735bf966283cc2201f1b65 SHA512 db77a3acb8a985b1df3d82eca7ac30fbd5e85bf3bc77f0f6da13af8064a7d4dc9d7fd57be3eabe5eecce610c8220ad493d296f2e425a8f69d62fddd1e419af1e
DIST prompt_toolkit-3.0.37.tar.gz 421637 BLAKE2B d8b0b8be846ff0ee9e35992d25e6153429a6d6316ea601f386c0cfeeec96119f9ddf109ca5a32e14a9ecae7badef808220722b5846cc984f2fd1dc7a18e3c763 SHA512 00e8b0d768c1449afd1c771a1b71611f291052ebed08c329cb9b34156588315b1d1202ac748293e6635c9ee78415068155565e69c2e632ae5513b61b670bd3fb
+DIST prompt_toolkit-3.0.38.tar.gz 422834 BLAKE2B 484ff9414d47f6f2188b8d50c6fcbe16ed850a8be880dfc60e9a3b750a26490f273b118d7bf0f1219530a59998273270b3b210750c35d00d7551ba15bb3f7e64 SHA512 eed2a73501d7ac413986f069564295db9eced3be4853a73c687e511ce1cf8c32c7c9bff4f851787e7910ed05818d4eb39556718c01f30e3ba8bfafe67d631a38
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.38.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.38.ebuild
new file mode 100644
index 000000000000..ca385c35243a
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.38.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest