summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-13 11:17:53 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-13 11:18:10 -0800
commit2e1d869be17fb570ff62f93de4510715aea63430 (patch)
tree3555538d91d62b6a31e41156794860a7f13e7755 /dev-python/prometheus_client
parentsys-apps/qdirstat: updated metadata.xml (diff)
downloadgentoo-2e1d869be17fb570ff62f93de4510715aea63430.tar.gz
gentoo-2e1d869be17fb570ff62f93de4510715aea63430.tar.bz2
gentoo-2e1d869be17fb570ff62f93de4510715aea63430.zip
dev-python/prometheus_client-0.7.1-r1: revbump, py38, EAPI=7
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.7.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/prometheus_client-0.7.1-r1.ebuild b/dev-python/prometheus_client/prometheus_client-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..55559cf445e0
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.7.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus_client/
+ https://github.com/prometheus/client_python"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/client_python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/twisted[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest