summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pp')
-rw-r--r--dev-python/pp/Manifest1
-rw-r--r--dev-python/pp/metadata.xml10
-rw-r--r--dev-python/pp/pp-1.6.4-r1.ebuild29
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pp/Manifest b/dev-python/pp/Manifest
new file mode 100644
index 000000000000..15fe775c4675
--- /dev/null
+++ b/dev-python/pp/Manifest
@@ -0,0 +1 @@
+DIST pp-1.6.4.tar.bz2 27166 SHA256 7f932d8eff4b35357bf5b48c1abd7734a955c98a50138c13b7b9eb36aadaf408 SHA512 213322aaa60e1485b855e96336a01c45407185892dede693c013a200554656ce08799ee23ee4a0cf628b382b98e0519445c99dbb89f209b1b907ac0a1fc8147e WHIRLPOOL fce8fe3ceaeb9e1d4133734107924faec6bcc5b4d862a37629443d0ec1774504956271dfa1af7de8dd2c06012e488e99dbe1220705fe3f4ae7c8cc8f721211da
diff --git a/dev-python/pp/metadata.xml b/dev-python/pp/metadata.xml
new file mode 100644
index 000000000000..d95e954c9ea7
--- /dev/null
+++ b/dev-python/pp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ PP is a python module which provides mechanism for parallel
+ execution of python code on SMP (systems with multiple processors or
+ cores) and clusters (computers connected via network).
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pp/pp-1.6.4-r1.ebuild b/dev-python/pp/pp-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..167f813ba571
--- /dev/null
+++ b/dev-python/pp/pp-1.6.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parallel and distributed programming for Python"
+HOMEPAGE="http://www.parallelpython.com/"
+SRC_URI="http://www.parallelpython.com/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+python_install_all() {
+ doman doc/ppserver.1
+ use doc && HTML_DOCS=( doc/ppdoc.html )
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}/examples"
+ fi
+ distutils-r1_python_install_all
+}