summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 22:19:52 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 22:19:52 +0200
commit9b36ba0c999ebfcaea8c86b065493cdea0902ea5 (patch)
tree1390c86738a0a5acac38bd2b4bb9ea2eee6f55ed /dev-python/podman-py
parentdev-python/flask-compress: add 1.11 (diff)
downloadgentoo-9b36ba0c999ebfcaea8c86b065493cdea0902ea5.tar.gz
gentoo-9b36ba0c999ebfcaea8c86b065493cdea0902ea5.tar.bz2
gentoo-9b36ba0c999ebfcaea8c86b065493cdea0902ea5.zip
dev-python/podman-py: add 4.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/podman-py')
-rw-r--r--dev-python/podman-py/Manifest1
-rw-r--r--dev-python/podman-py/podman-py-4.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/podman-py/Manifest b/dev-python/podman-py/Manifest
index 0b329618d17e..1b1fb9b4130c 100644
--- a/dev-python/podman-py/Manifest
+++ b/dev-python/podman-py/Manifest
@@ -1 +1,2 @@
DIST podman-py-3.2.1.tar.gz 181095 BLAKE2B 5075a37d3ef20004424536bc1f9e6e08c842248fcb8d8235ebc354e832e78125fb19bd0001f7fd237ebc642e348368da90b634f0db8c84e23ef77e8cf99b71ad SHA512 656a5e61d9809e2866a071ff5b4792fb71fbe0f8cc05467b498718b74898acc39a970ba64fc08ffe70d9c34a9caeabc3d8ea07dcce856fec308b6ebd268b2fb0
+DIST podman-py-4.0.0.tar.gz 172208 BLAKE2B 79e153c9b8e064398f31ad270d0f84f1bcc8ba830d4240914004c5d4eb1fffa32496c5e88b8191b074b521510e2bf0b8ea211a481af8a0ba70e7b0d6c26efe10 SHA512 e1dd48c931871206aae11fbcc31a711eecda89e9c60f62d5616dc3219e073d3ba74d38f63a05d4688e97fb678d2e03f8cd883456f7e75f2d7e313aa859ca3e8f
diff --git a/dev-python/podman-py/podman-py-4.0.0.ebuild b/dev-python/podman-py/podman-py-4.0.0.ebuild
new file mode 100644
index 000000000000..e099fdce4995
--- /dev/null
+++ b/dev-python/podman-py/podman-py-4.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.2[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit
+}