summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-21 16:36:32 +0100
committerSam James <sam@gentoo.org>2023-02-21 16:19:10 +0000
commitdd937cfab2cda03f3ce0053312786499745f202f (patch)
treef3b482e275ed46f2511f28e368e57b53e0284653 /dev-python/pocketlint
parentdev-libs/libpfm: add 4.12.0 (diff)
downloadgentoo-dd937cfab2cda03f3ce0053312786499745f202f.tar.gz
gentoo-dd937cfab2cda03f3ce0053312786499745f202f.tar.bz2
gentoo-dd937cfab2cda03f3ce0053312786499745f202f.zip
dev-python/pocketlint: enable py3.11
- enable python3.11 support - enable tests, the same way how upstream runs the CI Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29705 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pocketlint')
-rw-r--r--dev-python/pocketlint/pocketlint-0.24.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pocketlint/pocketlint-0.24.ebuild b/dev-python/pocketlint/pocketlint-0.24.ebuild
index c546d6ff289a..6aacc9d7bff0 100644
--- a/dev-python/pocketlint/pocketlint-0.24.ebuild
+++ b/dev-python/pocketlint/pocketlint-0.24.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -26,3 +26,7 @@ RDEPEND="
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}]
"
+
+python_test() {
+ "${EPYTHON}" tests/pylint/runpylint.py || die "test failed with ${EPYTHON}"
+}