summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-17 00:45:17 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-17 00:54:33 -0500
commitcf03cf6a1f39d049367d4efeb515be68e72692b2 (patch)
treeea1832cc72d275869ba18f2b23452ec96cb1a8ab /dev-python/pgzero/pgzero-1.2.1-r2.ebuild
parentdev-python/pygame: enable py3.11, cythonize, adjust deps (diff)
downloadgentoo-cf03cf6a1f39d049367d4efeb515be68e72692b2.tar.gz
gentoo-cf03cf6a1f39d049367d4efeb515be68e72692b2.tar.bz2
gentoo-cf03cf6a1f39d049367d4efeb515be68e72692b2.zip
dev-python/pgzero: enable py3.11, use pep517
Tests pass, just enabled 3.11 on pygame so drive-by enabling here too. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pgzero/pgzero-1.2.1-r2.ebuild')
-rw-r--r--dev-python/pgzero/pgzero-1.2.1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pgzero/pgzero-1.2.1-r2.ebuild b/dev-python/pgzero/pgzero-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..8b2903c837aa
--- /dev/null
+++ b/dev-python/pgzero/pgzero-1.2.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A zero-boilerplate games programming framework based on Pygame"
+HOMEPAGE="https://pygame-zero.readthedocs.io/"
+SRC_URI="https://github.com/lordmauve/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ )
+"
+distutils_enable_tests unittest
+
+python_test() {
+ # Allow the tests to pass without real audio or video.
+ local -x SDL_AUDIODRIVER=dummy SDL_VIDEODRIVER=dummy
+ eunittest
+}