summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-09-12 12:19:39 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-09-12 12:19:39 +0100
commit3bb3803b4c2701413e841ca110cb1febc2fe3509 (patch)
treef649d48001d8e9c61e5c8cf8cb0eaa30fff002c9 /dev-python/pgzero/pgzero-1.2.1-r1.ebuild
parentmedia-libs/libsdl2: Install Doxygen documentation with USE=doc (diff)
downloadgentoo-3bb3803b4c2701413e841ca110cb1febc2fe3509.tar.gz
gentoo-3bb3803b4c2701413e841ca110cb1febc2fe3509.tar.bz2
gentoo-3bb3803b4c2701413e841ca110cb1febc2fe3509.zip
dev-python/pgzero: Fix DISTUTILS_USE_SETUPTOOLS, EAPI 8
Closes: https://bugs.gentoo.org/812740 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-python/pgzero/pgzero-1.2.1-r1.ebuild')
-rw-r--r--dev-python/pgzero/pgzero-1.2.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pgzero/pgzero-1.2.1-r1.ebuild b/dev-python/pgzero/pgzero-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..ce85ee0ed841
--- /dev/null
+++ b/dev-python/pgzero/pgzero-1.2.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1
+distutils_enable_tests unittest
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A zero-boilerplate games programming framework based on Pygame"
+HOMEPAGE="https://pygame-zero.readthedocs.io/"
+SRC_URI="https://github.com/lordmauve/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# Allow the tests to pass without real audio or video.
+export SDL_AUDIODRIVER=dummy SDL_VIDEODRIVER=dummy