summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-20 08:45:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-20 09:41:37 +0200
commite5dbb054e384b53631834798266606d31cb2e222 (patch)
treefc813cf508584dce2b03741396ce8407350e18f6 /dev-python/pdfrw
parentnet-mail/rss2email: py3[78] + QA (diff)
downloadgentoo-e5dbb054e384b53631834798266606d31cb2e222.tar.gz
gentoo-e5dbb054e384b53631834798266606d31cb2e222.tar.bz2
gentoo-e5dbb054e384b53631834798266606d31cb2e222.zip
dev-python/pdfrw: Enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pdfrw')
-rw-r--r--dev-python/pdfrw/Manifest1
-rw-r--r--dev-python/pdfrw/pdfrw-0.4.ebuild37
2 files changed, 35 insertions, 3 deletions
diff --git a/dev-python/pdfrw/Manifest b/dev-python/pdfrw/Manifest
index fdc7338493f7..b435bb703dcb 100644
--- a/dev-python/pdfrw/Manifest
+++ b/dev-python/pdfrw/Manifest
@@ -1 +1,2 @@
DIST pdfrw-0.4.tar.gz 95402 BLAKE2B 00f01f8d4cca9c5306d08094639d4cb10c53aca1c81b6c65f5639c8862a067e562c164523cc58abddb06b39dabcc50c2fbcdcf04a291309cac709cbfd0cf4673 SHA512 6c0b629e837f9bd479a288bcd040952b98920da345113bf90167becbdf2f90a9d6c082c5e7988c68118bd62a2a5a0d22f98523407996531bb5d3031e847e10b0
+DIST pdfrw-static_pdfs-d646009a0e3e71daf13a52ab1029e2230920ebf4.tar.gz 25243391 BLAKE2B 5c491d56c9731352907787bbe10b8b3ac362f0c7892ddcd15a1299d3b2b4bb604662f6231aa22478290992a345e769af2e2c2459a25a16c370ea05fa68101f80 SHA512 9bf1d5ddc8f55b40b50041e745579406bb0036fb7795ac40064aad7cdf592869051ba84a5ab080042e237690bb2f1811b86b2a4424535aa4c367f6e29a0c34eb
diff --git a/dev-python/pdfrw/pdfrw-0.4.ebuild b/dev-python/pdfrw/pdfrw-0.4.ebuild
index 8a587df57675..3c4fb0e43fe8 100644
--- a/dev-python/pdfrw/pdfrw-0.4.ebuild
+++ b/dev-python/pdfrw/pdfrw-0.4.ebuild
@@ -7,13 +7,44 @@ PYTHON_COMPAT=( python2_7 python3_6 )
inherit distutils-r1
+PDFS_COMMIT=d646009a0e3e71daf13a52ab1029e2230920ebf4
DESCRIPTION="PDF file reader/writer library"
HOMEPAGE="https://github.com/pmaupin/pdfrw"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? (
+ https://github.com/pmaupin/static_pdfs/archive/${PDFS_COMMIT}.tar.gz
+ -> pdfrw-static_pdfs-${PDFS_COMMIT}.tar.gz
+ )"
LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ppc ppc64 sparc x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/reportlab[${PYTHON_USEDEP}] )"
+
+# unittest would be sufficient but its output is unreadable
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "static_pdfs-${PDFS_COMMIT}"/* "${P}"/tests/static_pdfs/ || die
+ fi
+}
+
+src_prepare() {
+ # broken upstream (sensitive to reportlab version?)
+ sed -e 's:test_rl1_platypus:_&:' \
+ -i tests/test_examples.py || die
+ # fails with py3
+ sed -e '/repaginate\/7037/s:dd41b0104f185206b51e7ffe5b07d261:skip:' \
+ -i tests/expected.txt || die
+
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}