summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-16 10:02:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-16 11:07:44 +0200
commitcfd47eb1d2540122ca87dd6fd324f223529bd1fa (patch)
tree8973ebdd6043f52d793a107ffd1b2238d755666e /dev-python/path-py
parentdev-python/path-py: Add anti-dep breaking blocker on pytest-shutil (diff)
downloadgentoo-cfd47eb1d2540122ca87dd6fd324f223529bd1fa.tar.gz
gentoo-cfd47eb1d2540122ca87dd6fd324f223529bd1fa.tar.bz2
gentoo-cfd47eb1d2540122ca87dd6fd324f223529bd1fa.zip
dev-python/path-py: Disable fragile timing tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/path-py-11.5.2.ebuild3
-rw-r--r--dev-python/path-py/path-py-12.0.2-r2.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/path-py/path-py-11.5.2.ebuild b/dev-python/path-py/path-py-11.5.2.ebuild
index c95f162bf185..dd854041c4dd 100644
--- a/dev-python/path-py/path-py-11.5.2.ebuild
+++ b/dev-python/path-py/path-py-11.5.2.ebuild
@@ -44,6 +44,9 @@ python_prepare_all() {
sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' \
pytest.ini || die
+ # fragile test for import time
+ sed -i -e 's:test_import_time:_&:' test_path.py || die
+
distutils-r1_python_prepare_all
}
diff --git a/dev-python/path-py/path-py-12.0.2-r2.ebuild b/dev-python/path-py/path-py-12.0.2-r2.ebuild
index 511276e331da..caa323eb0ce0 100644
--- a/dev-python/path-py/path-py-12.0.2-r2.ebuild
+++ b/dev-python/path-py/path-py-12.0.2-r2.ebuild
@@ -47,6 +47,9 @@ python_prepare_all() {
sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' \
pytest.ini || die
+ # fragile test for import time
+ sed -i -e 's:test_import_time:_&:' test_path.py || die
+
distutils-r1_python_prepare_all
}