summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-16 08:31:57 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-16 09:09:36 +0100
commit9950f78597ada968a7dc4d09f23701f4b420f532 (patch)
tree6881786bd2f56d9ef4906f38a6bfa700b4d628c7 /dev-python/parso
parentdev-python/hypothesis: Bump to 4.54.0 (diff)
downloadgentoo-9950f78597ada968a7dc4d09f23701f4b420f532.tar.gz
gentoo-9950f78597ada968a7dc4d09f23701f4b420f532.tar.bz2
gentoo-9950f78597ada968a7dc4d09f23701f4b420f532.zip
dev-python/parso: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest1
-rw-r--r--dev-python/parso/parso-0.5.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index 31618dcb1b46..5a0c4f9dd07b 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1,3 +1,4 @@
DIST parso-0.3.1.tar.gz 375226 BLAKE2B 71481f5f382f14e5f2c7826f8eb50a1c35f8c280f14c8bf52bcf44f77aa9872cddce7d7fb7b0a586ab7cda547e43bbce11812077ae84129c418a9f0bb3c5b856 SHA512 f83e316a41e21d3132d9ee8a45f9042962c01a2b906e8791046112b9ed938d378b0dc28c4ae05ce03a8c2d19563a49cba9a9a230654345ff62e87cc763536ddb
DIST parso-0.5.0.tar.gz 386652 BLAKE2B f12e34aa9b93a1d3eedca96588148ac1e9ecb3a6af3910627d251e2281df285ce8768c11bf3cac35f8a977f0dac2f7a906fb20171db35fae2bec1c60cd0d7dc6 SHA512 cd2a38e538faf4faf3f1828f4e69dfe685ef1fd3e120326ca5260f0edbc23952e51ffd8370a2bb2de513a90ecde76e6ea2fe76d84d3ab4115c7817e3af08e701
DIST parso-0.5.1.tar.gz 388060 BLAKE2B 429ab40501d38e982cf77e0dbbfa4d8677dd1e2400945436b8eced608a41015b7028f586cf9af6057e441765f0a1db519a642ceadaba14620a92f452ce709871 SHA512 a04ef9bbe156bc28ac9fa64d091d3f1dcc9cf4b15a3c109cd33de1c4d34d0bf741016b88b6c12d456e953253942b7d522e0b793c9a00e9fb06de27ab0667c7fc
+DIST parso-0.5.2.tar.gz 390495 BLAKE2B 257de5853cad74803d9b45ae4820c96933d09ebe7c09d30a98ccb1d40d1473d8ef55f9be692278012f3d6f57066600ae14817d20bbde2258f2362702f3056f93 SHA512 d8a2b8c4f30eec676f9cb36afc86b4f80d8397ce4d82a2452598116ae50cb861a1eea6543a51898f4c94acb13b8345833283a353f19ae27242b6e993c02f0ef7
diff --git a/dev-python/parso/parso-0.5.2.ebuild b/dev-python/parso/parso-0.5.2.ebuild
new file mode 100644
index 000000000000..f5c44e291ec2
--- /dev/null
+++ b/dev-python/parso/parso-0.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest