summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-17 13:04:26 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-17 13:08:00 +0100
commitf43cbb8edede6496156480e4566c1ad75cca943a (patch)
tree0e7eecca9b7a23bb8e0c4e55903a4de5ef4682ba /dev-python/pandas
parentdev-python/xlrd: Bump to 2.0.1 (diff)
downloadgentoo-f43cbb8edede6496156480e4566c1ad75cca943a.tar.gz
gentoo-f43cbb8edede6496156480e4566c1ad75cca943a.tar.bz2
gentoo-f43cbb8edede6496156480e4566c1ad75cca943a.zip
dev-python/pandas: Revert all the recent changes
Revert the removal of xlrd and xlwt deps, as well FMA-related changes, bringing the ebuilds back to -r1. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/pandas-1.1.5-r1.ebuild (renamed from dev-python/pandas/pandas-1.1.5-r2.ebuild)7
-rw-r--r--dev-python/pandas/pandas-1.2.1-r1.ebuild (renamed from dev-python/pandas/pandas-1.2.1-r4.ebuild)13
-rw-r--r--dev-python/pandas/pandas-1.2.2-r1.ebuild (renamed from dev-python/pandas/pandas-1.2.2-r2.ebuild)7
-rw-r--r--dev-python/pandas/pandas-1.2.3-r1.ebuild (renamed from dev-python/pandas/pandas-1.2.3-r4.ebuild)13
4 files changed, 28 insertions, 12 deletions
diff --git a/dev-python/pandas/pandas-1.1.5-r2.ebuild b/dev-python/pandas/pandas-1.1.5-r1.ebuild
index 3ddd497a8211..75aeaa4bcee4 100644
--- a/dev-python/pandas/pandas-1.1.5-r2.ebuild
+++ b/dev-python/pandas/pandas-1.1.5-r1.ebuild
@@ -46,6 +46,8 @@ OPTIONAL_DEPEND="
>=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
' python3_{6,7})
>=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-1.0.0[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
>=dev-python/scipy-1.1[${PYTHON_USEDEP}]
X? (
|| (
@@ -77,6 +79,8 @@ DEPEND="${COMMON_DEPEND}
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/rpy[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
x11-misc/xclip
)
@@ -96,7 +100,6 @@ DEPEND="${COMMON_DEPEND}
dev-python/xlsxwriter[${PYTHON_USEDEP}]
x11-misc/xclip
x11-misc/xsel
- !!dev-python/xlwt
)
"
# dev-python/statsmodels invokes a circular dep
@@ -169,7 +172,7 @@ pkg_postinst() {
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
- optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter
+ optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
optfeature "necessary for HDF5-based storage" ">=dev-python/pytables-3.2.1"
optfeature "R I/O support" dev-python/rpy
optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
diff --git a/dev-python/pandas/pandas-1.2.1-r4.ebuild b/dev-python/pandas/pandas-1.2.1-r1.ebuild
index 215cfe646ee9..05a432d36557 100644
--- a/dev-python/pandas/pandas-1.2.1-r4.ebuild
+++ b/dev-python/pandas/pandas-1.2.1-r1.ebuild
@@ -46,6 +46,8 @@ OPTIONAL_DEPEND="
>=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
' python3_{6,7})
>=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-1.0.0[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
>=dev-python/scipy-1.1[${PYTHON_USEDEP}]
X? (
|| (
@@ -77,6 +79,8 @@ DEPEND="${COMMON_DEPEND}
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/rpy[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
x11-misc/xclip
)
@@ -96,7 +100,6 @@ DEPEND="${COMMON_DEPEND}
dev-python/xlsxwriter[${PYTHON_USEDEP}]
x11-misc/xclip
x11-misc/xsel
- !!dev-python/xlwt
)
"
# dev-python/statsmodels invokes a circular dep
@@ -138,8 +141,10 @@ src_test() {
python_test() {
local deselect=(
- # test for rounding errors, fails if we have better precision
- 'pandas/tests/window/test_rolling.py::test_rolling_var_numerical_issues'
+ # broken on practically any hardware/CFLAGS but the one
+ # the patch author was using
+ # https://github.com/pandas-dev/pandas/issues/38921
+ pandas/tests/window/test_rolling.py::test_rolling_var_numerical_issues
# weird issue, doesn't seem very important
'pandas/tests/base/test_misc.py::test_memory_usage[series-with-empty-index]'
@@ -175,7 +180,7 @@ pkg_postinst() {
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
- optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter
+ optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
optfeature "necessary for HDF5-based storage" ">=dev-python/pytables-3.2.1"
optfeature "R I/O support" dev-python/rpy
optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
diff --git a/dev-python/pandas/pandas-1.2.2-r2.ebuild b/dev-python/pandas/pandas-1.2.2-r1.ebuild
index 98ce6571d617..a79b5b1c18ca 100644
--- a/dev-python/pandas/pandas-1.2.2-r2.ebuild
+++ b/dev-python/pandas/pandas-1.2.2-r1.ebuild
@@ -46,6 +46,8 @@ OPTIONAL_DEPEND="
>=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
' python3_{6,7})
>=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-1.0.0[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
>=dev-python/scipy-1.1[${PYTHON_USEDEP}]
X? (
|| (
@@ -77,6 +79,8 @@ DEPEND="${COMMON_DEPEND}
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/rpy[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
x11-misc/xclip
)
@@ -96,7 +100,6 @@ DEPEND="${COMMON_DEPEND}
dev-python/xlsxwriter[${PYTHON_USEDEP}]
x11-misc/xclip
x11-misc/xsel
- !!dev-python/xlwt
)
"
# dev-python/statsmodels invokes a circular dep
@@ -177,7 +180,7 @@ pkg_postinst() {
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
- optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter
+ optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
optfeature "necessary for HDF5-based storage" ">=dev-python/pytables-3.2.1"
optfeature "R I/O support" dev-python/rpy
optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
diff --git a/dev-python/pandas/pandas-1.2.3-r4.ebuild b/dev-python/pandas/pandas-1.2.3-r1.ebuild
index 6eca3b657e87..a79b5b1c18ca 100644
--- a/dev-python/pandas/pandas-1.2.3-r4.ebuild
+++ b/dev-python/pandas/pandas-1.2.3-r1.ebuild
@@ -46,6 +46,8 @@ OPTIONAL_DEPEND="
>=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
' python3_{6,7})
>=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-1.0.0[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
>=dev-python/scipy-1.1[${PYTHON_USEDEP}]
X? (
|| (
@@ -77,6 +79,8 @@ DEPEND="${COMMON_DEPEND}
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/rpy[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
x11-misc/xclip
)
@@ -96,7 +100,6 @@ DEPEND="${COMMON_DEPEND}
dev-python/xlsxwriter[${PYTHON_USEDEP}]
x11-misc/xclip
x11-misc/xsel
- !!dev-python/xlwt
)
"
# dev-python/statsmodels invokes a circular dep
@@ -138,8 +141,10 @@ src_test() {
python_test() {
local deselect=(
- # test for rounding errors, fails if we have better precision
- 'pandas/tests/window/test_rolling.py::test_rolling_var_numerical_issues'
+ # broken on practically any hardware/CFLAGS but the one
+ # the patch author was using
+ # https://github.com/pandas-dev/pandas/issues/38921
+ pandas/tests/window/test_rolling.py::test_rolling_var_numerical_issues
# weird issue, doesn't seem very important
'pandas/tests/base/test_misc.py::test_memory_usage[series-with-empty-index]'
@@ -175,7 +180,7 @@ pkg_postinst() {
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
- optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter
+ optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
optfeature "necessary for HDF5-based storage" ">=dev-python/pytables-3.2.1"
optfeature "R I/O support" dev-python/rpy
optfeature "Needed for parts of pandas.stats" dev-python/statsmodels