summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-08-30 11:51:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-08-30 12:09:06 -0500
commitb20b0b3b276df43d8c98e3b8f98ce026bb284cdc (patch)
tree38d5578dc9240db9f442a82e2b6550adede20042 /dev-python/oslo-context/oslo-context-2.21.0.ebuild
parentdev-python/oslo-concurrency: 3.27.0 bump (diff)
downloadgentoo-b20b0b3b276df43d8c98e3b8f98ce026bb284cdc.tar.gz
gentoo-b20b0b3b276df43d8c98e3b8f98ce026bb284cdc.tar.bz2
gentoo-b20b0b3b276df43d8c98e3b8f98ce026bb284cdc.zip
dev-python/oslo-context: 2.21.0 bump
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/oslo-context/oslo-context-2.21.0.ebuild')
-rw-r--r--dev-python/oslo-context/oslo-context-2.21.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/oslo-context/oslo-context-2.21.0.ebuild b/dev-python/oslo-context/oslo-context-2.21.0.ebuild
new file mode 100644
index 000000000000..4d0db0d234d3
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-2.21.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.org/project/oslo.context/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.context-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+# This time half the doc files are missing; Do you want them?
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}