summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-19 01:38:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-19 01:38:15 -0500
commit328baff688c3ae68722aa39909e6f4877c632ce4 (patch)
tree398312eb72d27a8e664a5b4a52e00faac2b78768 /dev-python/oslo-context/oslo-context-0.6.0.ebuild
parentsys-cluster/cinder: removing unneeded files (diff)
downloadgentoo-328baff688c3ae68722aa39909e6f4877c632ce4.tar.gz
gentoo-328baff688c3ae68722aa39909e6f4877c632ce4.tar.bz2
gentoo-328baff688c3ae68722aa39909e6f4877c632ce4.zip
dev-python/oslo-context: bup for liberty
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/oslo-context/oslo-context-0.6.0.ebuild')
-rw-r--r--dev-python/oslo-context/oslo-context-0.6.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/oslo-context/oslo-context-0.6.0.ebuild b/dev-python/oslo-context/oslo-context-0.6.0.ebuild
new file mode 100644
index 000000000000..a69f6f72aa60
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-0.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.context"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+S="${WORKDIR}/oslo.context-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+# This time half the doc files are missing; Do you want them?
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}