summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-15 19:43:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-15 19:50:34 +0200
commit4662624d6067b4aa4aeafdcee06a59b93fe305fe (patch)
tree4c5703d66d67a41c2f5bbc4015c1ce9043119542 /dev-python/oslo-config
parentgames-strategy/wargus: Bump to 3.1.1 (diff)
downloadgentoo-4662624d6067b4aa4aeafdcee06a59b93fe305fe.tar.gz
gentoo-4662624d6067b4aa4aeafdcee06a59b93fe305fe.tar.bz2
gentoo-4662624d6067b4aa4aeafdcee06a59b93fe305fe.zip
dev-python/oslo-config: Bump to 8.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/Manifest1
-rw-r--r--dev-python/oslo-config/oslo-config-8.7.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/oslo-config/Manifest b/dev-python/oslo-config/Manifest
index e8f08a52b5b5..230243f28627 100644
--- a/dev-python/oslo-config/Manifest
+++ b/dev-python/oslo-config/Manifest
@@ -1 +1,2 @@
DIST oslo-config-8.3.3.tar.gz 154910 BLAKE2B d9d3d45d3f9bd191e2be9ef277719d723c35d36006836b2803dfa973283432745d6f11c7d764f2cf4a9ce62098cc0b94ba6aecb364869fd8957ffa309d47bb38 SHA512 6071fbcb4f9e641e6914d676bab3f58cd9e763219bcce0f7de16017a4e1d3a16fcf4296a36c232ac14d8c5c4555f4c433fedc1811e505e62decb0400a9cc2a7c
+DIST oslo-config-8.7.1.tar.gz 160536 BLAKE2B 71221141226024b6e7257c74afd082f297980bd45091de1a30c526d52c5514b970983c9389b82bb49283ef2176b7fc408f4b7f3fc29f9d6cdccb513652b7bee2 SHA512 a76995ff12204968fd9a52ca2922a89039858392b21befff827bf02c3466e365251d90e2d02894a50bece32751e9f5f86a651768665f404de2d3a438e53f158d
diff --git a/dev-python/oslo-config/oslo-config-8.7.1.ebuild b/dev-python/oslo-config/oslo-config-8.7.1.ebuild
new file mode 100644
index 000000000000..e0f0e4b92ca8
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-8.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Configuration API"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+"
+BDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+python_test() {
+ local -x COLUMNS=80
+ eunittest -b
+}