summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 18:12:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 18:12:53 -0500
commit40d03b9076adb22ce1ff7a86af669bd12023cd9e (patch)
tree2da43cecf6af0719985b06138b18c0d3acb19b5c /dev-python/os-brick/os-brick-1.1.0.ebuild
parentdev-python/os-win: adding for mitaka (diff)
downloadgentoo-40d03b9076adb22ce1ff7a86af669bd12023cd9e.tar.gz
gentoo-40d03b9076adb22ce1ff7a86af669bd12023cd9e.tar.bz2
gentoo-40d03b9076adb22ce1ff7a86af669bd12023cd9e.zip
dev-python/os-brick: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/os-brick/os-brick-1.1.0.ebuild')
-rw-r--r--dev-python/os-brick/os-brick-1.1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/os-brick/os-brick-1.1.0.ebuild b/dev-python/os-brick/os-brick-1.1.0.ebuild
new file mode 100644
index 000000000000..2cff5ccee6a1
--- /dev/null
+++ b/dev-python/os-brick/os-brick-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/cinder"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}