summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-15 08:14:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-15 08:35:09 +0100
commit697f35eb854cd8b75f41d2797b92f69699f64432 (patch)
treec485bd83c87211132d419417c9ba3ac46d8fb37e /dev-python/openpyxl
parentdev-python/boto3: Bump to 1.16.55 (diff)
downloadgentoo-697f35eb854cd8b75f41d2797b92f69699f64432.tar.gz
gentoo-697f35eb854cd8b75f41d2797b92f69699f64432.tar.bz2
gentoo-697f35eb854cd8b75f41d2797b92f69699f64432.zip
dev-python/openpyxl: Bump to 3.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/Manifest1
-rw-r--r--dev-python/openpyxl/openpyxl-3.0.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index 28137ca67982..19cdb5d81b0d 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1 +1,2 @@
DIST openpyxl-3.0.5.tar.bz2 2421647 BLAKE2B 60fc12188a608891a63513177e8e3399b3905ee9b4c4ff1631901ce0d99c3e05bc9413813d3c4f7bb9034e1d839f91e9dea5e610795c701a40d99f1011b08c45 SHA512 5f60f746b7b4bd32a018972f7c18adc0552a6d6904fcf1258db3fab28f21aa7b17e386b355ede41365889146e9aaa09911748a26343788477fd72ad5d1264974
+DIST openpyxl-3.0.6.tar.bz2 2423464 BLAKE2B 205db09634730a1da6c24bc8c407b2f3deeac712b4c2cbe69796c538c6911ccb3e7e003617ab9563df12a74d6ca9fb2b1b83d8d75f3b91c168d2053a14c15d66 SHA512 6996800c54746dc41b902cbea378181cdab5db916fd6863c673df25f84f71de67019e34d0034231d7c588bf56be3f8e16b3a52c198dcbe74465d0b088090c24a
diff --git a/dev-python/openpyxl/openpyxl-3.0.6.ebuild b/dev-python/openpyxl/openpyxl-3.0.6.ebuild
new file mode 100644
index 000000000000..5c4d4f8c1c20
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+SRC_URI="https://foss.heptapod.net/openpyxl/openpyxl/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest