summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 10:54:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 11:59:00 +0200
commit123d4d45a052af62196756ab0cc6dc3ba9833858 (patch)
treeea565ef46a78fe3fc232fec82e7319ee5f8d998d /dev-python/nuitka
parentapp-admin/awscli: Bump to 1.25.49 (diff)
downloadgentoo-123d4d45a052af62196756ab0cc6dc3ba9833858.tar.gz
gentoo-123d4d45a052af62196756ab0cc6dc3ba9833858.tar.bz2
gentoo-123d4d45a052af62196756ab0cc6dc3ba9833858.zip
dev-python/nuitka: Bump to 1.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.0.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index a2e7708d4099..2d2d9b9cb363 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-1.0.1.tar.gz 3893766 BLAKE2B 7d48344231fca1efce8d783a197813a1aa77c992fad84c1a958740287ea8079566c98bb6ac1e017030a6d6dba84bdef6a7711542adaa8a59612aed19da96f425 SHA512 0d3ba38733fdee4f6f4bff80fd2c7729177209e101f0eefe2c5a74fd449d038710eb979e1b313c1534bfe079ea3a7f88cda07ba2977c153032a56db0b75f739c
DIST Nuitka-1.0.2.tar.gz 3893195 BLAKE2B 7d3f154ecb128da34f1495d977ec81bc54dcd95d5d53d3ef437a0a55f11f91529eb12c985eba6256d53d2746e0b2925a50ab4fd19967f602c552a57c1ec51408 SHA512 a1cd4ba3b2ced48fd2b8fdd2438f8b6108ce3638fb59507bd2398cc8d3e9c9eb9b93d86446e960d26df351c2769799df3a8ca248482eee531dd6bbc276036a90
+DIST Nuitka-1.0.3.tar.gz 3894225 BLAKE2B 9e29cfc23c4c1fda50330a6ebfb30fe8a13b18486a87965e9b4daddedd6fb38f6f3c89c606ff63d7a0888bc1c329c593a92d36cfc6b0d2b46a289fa4fd6fc8f5 SHA512 68bab7f431e2469c01c8e3272ea75eff8bffe7a070768759949206109fc4bb035243e3b2511372ec449fe07aff9bc94185f2b3c3301d5e847d091fa340522362
diff --git a/dev-python/nuitka/nuitka-1.0.3.ebuild b/dev-python/nuitka/nuitka-1.0.3.ebuild
new file mode 100644
index 000000000000..5b987e13729d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}