summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/nevow
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/nevow')
-rw-r--r--dev-python/nevow/Manifest1
-rw-r--r--dev-python/nevow/metadata.xml8
-rw-r--r--dev-python/nevow/nevow-0.11.1-r1.ebuild50
-rw-r--r--dev-python/nevow/nevow-0.11.1.ebuild41
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/nevow/Manifest b/dev-python/nevow/Manifest
new file mode 100644
index 000000000000..a0c9b74d85d0
--- /dev/null
+++ b/dev-python/nevow/Manifest
@@ -0,0 +1 @@
+DIST Nevow-0.11.1.tar.gz 563061 SHA256 89d7f6943cf81ccef8dde4016caa1cba977b9366e7aa0660b54239828b421efc SHA512 a7e52fbf6915498e77a41fb100d4c688fcd0567deb56ec946adf1b1712bcfbec7b7a55c551e414606218146772d5274973af7851a78878635e900a4df5193a53 WHIRLPOOL a82ca1334abf201ef9fcf22e579be778e819c488df8c9f774bef7f13041aa996f630408f4a8428e74b2e79df1904dbdf2f858fb79526a9417c1872da95a24963
diff --git a/dev-python/nevow/metadata.xml b/dev-python/nevow/metadata.xml
new file mode 100644
index 000000000000..991dd94eb658
--- /dev/null
+++ b/dev-python/nevow/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Nevow</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nevow/nevow-0.11.1-r1.ebuild b/dev-python/nevow/nevow-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..577984d22bb8
--- /dev/null
+++ b/dev-python/nevow/nevow-0.11.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="A web templating framework that provides LivePage, an automatic AJAX toolkit"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodNevow http://pypi.python.org/pypi/Nevow"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+TWISTED_PLUGINS=( nevow.plugins )
+
+FAILING_TESTS=(
+ nevow/test/test_url.py
+ nevow/test/test_loaders.py
+ nevow/test/test_appserver.py
+ formless/test/test_freeform.py
+)
+
+python_test() {
+ # See bug 355237
+ rm -v ${FAILING_TESTS[@]} || die "can't remove failing tests"
+ trial formless nevow || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ touch "${D}$(python_get_sitedir)"/nevow/plugins/dropin.cache || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # TODO: prevent installing it
+ rm -r "${D}"/usr/doc || die
+}
diff --git a/dev-python/nevow/nevow-0.11.1.ebuild b/dev-python/nevow/nevow-0.11.1.ebuild
new file mode 100644
index 000000000000..ff450e4ec628
--- /dev/null
+++ b/dev-python/nevow/nevow-0.11.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="A web templating framework that provides LivePage, an automatic AJAX toolkit"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodNevow http://pypi.python.org/pypi/Nevow"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+TWISTED_PLUGINS=( nevow.plugins )
+
+python_test() {
+ trial formless nevow || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ touch "${D}$(python_get_sitedir)"/nevow/plugins/dropin.cache || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # TODO: prevent installing it
+ rm -r "${D}"/usr/doc || die
+}